В10 — ЯП — массивы

Всего заданий в разделе: 103


№1 (Номер в базе opengia.com: Задание №006537 . Номер в базе ComputerScienceForAll.ru: 3024)

В таблице Pos хранятся данные о количестве посетителей школьного музея за семь дней (Pos[1] – данные за первый день, Pos[2] – за второй день и т.д.). Определите число, которое будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

 целтаб Pos[1:7]

 цел  k, m, day

 Pos[1] := 17

 Pos[2] := 19

 Pos[3] := 20

 Pos[4] := 18

 Pos[5] := 16

 Pos[6] := 20

 Pos[7] := 16

 day:= 1

 m:=Pos[1]

 нц для k от 2 до 7

  если Pos[k] < m то

    m := Pos[k]

    day := k

  все

 кц

 вывод day

кон

DIM Pos(7)AS INTEGER

 Pos(1) = 17

 Pos(2) = 19

 Pos(3) = 20

 Pos(4) = 18

 Pos(5) = 16

 Pos(6) = 20

 Pos(7) = 16

 day = 1

 m = Pos(1)

FOR k = 2 TO 7

 IF Pos(k) < m THEN

   m = Pos(k)

   day = k

 END IF

NEXT k

PRINT day

END

Var k, m, day: integer;

 Pos: array[1..7] of integer;

Begin

 Pos[1] := 17; 

 Pos[2] := 19;

 Pos[3] := 20;

 Pos[4] := 18;

 Pos[5] := 16; 

 Pos[6] := 20;

 Pos[7] := 16; 

 day := 1; m := Pos[1];

 for k:=2 to 7 do begin

   if  Pos[k] < m then

     begin

       m := Pos[k];

       day := k

     end

 end;

 write(day);

End.


№2 (Номер в базе opengia.com: Задание №022c25 . Номер в базе ComputerScienceForAll.ru: 3035)

В таблице Dat хранятся отметки учащихся 9 класса за самостоятельную работу  (Dat[1] – отметка первого учащегося, Dat[2] – второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  целтаб Dat[1:10]

  цел k, m

  Dat[1] := 4

  Dat[2] := 5

  Dat[3] := 4

  Dat[4] := 3

  Dat[5] := 2

  Dat[6] := 3

  Dat[7] := 4

  Dat[8] := 5

  Dat[9] := 5

  Dat[10] := 3

  m := 0

  нц для k от 1 до 10

    если Dat[k] < 4 то

    m := m + Dat[k]

  все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k, m AS INTEGER

Dat(1) = 4: Dat(2) = 5

Dat(3) = 4: Dat(4) = 3

Dat(5) = 2: Dat(6) = 3

Dat(7) = 4: Dat(8) = 5

Dat(9) = 5: Dat(10) = 3

m = 0

FOR k = 1 TO 10

IF Dat(k) < 4 THEN

m = m + Dat(k)

ENDIF

NEXT k

PRINT m

END

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 4; Dat[2] := 5;

  Dat[3] := 4; Dat[4] := 3;

  Dat[5] := 2; Dat[6] := 3;

  Dat[7] := 4; Dat[8] := 5;

  Dat[9] := 5; Dat[10] := 3;

  m := 0;

  for k := 1 to 10 do

    if Dat[k] < 4 then

      begin

        m := m + Dat[k];

      end;

  writeln(m);

End.


№3 (Номер в базе opengia.com: Задание №02a2e9 . Номер в базе ComputerScienceForAll.ru: 3042)

В таблице Ball хранятся баллы, набранные участниками школьного тура олимпиады по математике (Ball[1] – балл 1 ученика, Ball[2] – балл 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

    целтаб Ball[1:10]

    цел k, m

    Ball[1]:=42; Ball[2]:=25

    Ball[3]:=13; Ball[4]:=18

    Ball[5]:=15; Ball[6]:=55

    Ball[7]:=48; Ball[8]:=13

    Ball[9]:=64; Ball[10]:=45

    m := Ball[1]

    нц для k от 1 до 10

         если Ball[k] < m то

              m := Ball[k]

         все

    кц

    вывод m

кон

DIM Ball(10) AS INTEGER

DIM k, m AS INTEGER

Ball(1)=42: Ball(2)=25

Ball(3)=13: Ball(4)=18

Ball(5)=15: Ball(6)=55

Ball(7)=48: Ball(8)=13

Ball(9)=64: Ball(10)=45

m := Ball(1)

FOR k = 1 TO 10

IF Ball(k) < m THEN

m := Ball(k)

END IF

NEXT k

PRINT m

Var k, m, t: integer;

Ball: array[1..10] of integer;

Begin

Ball[1]:=42; Ball[2]:=25;

Ball[3]:=13; Ball[4]:=18;

Ball[5]:=15; Ball[6]:=55;

Ball[7]:=48; Ball[8]:=13;

Ball[9]:=64; Ball[10]:=45;

m := Ball[1];

for k := 1 to 10 do

if Ball[k] < m then

m := Ball[k];

write(m);

End.


№4 (Номер в базе opengia.com: Задание №04a1d5 . Номер в базе ComputerScienceForAll.ru: 3053)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 15 до 19

   s := s+8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 15 TO 19

s = s+8

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 15 to 19 do

   s := s+8;

 writeln(s);

End.


№5 (Номер в базе opengia.com: Задание №0F02E0 . Номер в базе ComputerScienceForAll.ru: 3103)

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй
и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 12

  Dat[2] := 15

  Dat[3] := 17

  Dat[4] := 15

  Dat[5] := 14

  Dat[6] := 12

  Dat[7] := 10

  Dat[8] := 13

  Dat[9] := 14

  Dat[10] := 15

  m := 20

  нц для k от 1 до 10

    если Dat[k]то

     m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 20 

FOR k = 1 TO 10

IF Dat(k)

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 12; Dat[2] := 15;

 Dat[3] := 17; Dat[4] := 15;

 Dat[5] := 14; Dat[6] := 12;

 Dat[7] := 10; Dat[8] := 13;

 Dat[9] := 14; Dat[10] := 15;

 m := 20;

 for k := 1 to 10 do

   if  Dat[k]

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


№6 (Номер в базе opengia.com: Задание №0e9ce0 . Номер в базе ComputerScienceForAll.ru: 3119)

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  цел s, k

  s:=1

  нц для k от 1 до 5

    s:=s * k

  кц

  вывод s

кон

DIM s, k AS INTEGER

s = 1

FOR k = 1 TO 5

 s = s * k

NEXT k

PRINT s

END

Var s,k: integer;

Begin

 s:=1;

 for k:=1 to 5 do

   s:=s * k;

 write(s);

End.


№7 (Номер в базе opengia.com: Задание №1079fd . Номер в базе ComputerScienceForAll.ru: 3126)

В таблице Work хранятся данные о количестве заказов, принятых фирмой «Конфетти» с первого по 15 декабря.  (Work[1] – число заказов, принятых 1 декабря, Work[2] – 2 декабря и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

    целтаб Work[1:15]

    цел k, m

    Work[1] := 5; Work[2] := 4

    Work[3] := 5; Work[4] := 7

    Work[5] := 6; Work[6] := 12

    Work[7] := 7; Work[8] := 3

    Work[9] := 9; Work[10] := 7

    Work[11] := 0;Work[12] := 9

    Work[13] := 1;Work[14] := 0

    Work[15] := 8;

    m := 0

    нц для k от 1 до 15

        если Work[k] > 6 то

         m := m + 1

        все

    кц

    вывод m

кон

DIM Work(15) AS INTEGER

DIM k,m AS INTEGER

Work(1)= 5:  Work(2)= 4

Work(3)= 5:  Work(4) = 7

Work(5)= 6:  Work(6)= 12

Work(7)= 7:  Work(8)= 3

Work(9)= 9:  Work(10)= 7

Work(11)= 0: Work(12)= 9

Work(13)= 1: Work(14)= 0

Work(15)= 8

m = 0

FOR k = 1 TO 15

IF Work(k) > 6 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

  Work: array[1..15] of integer;

Begin

  Work[1] := 5;   Work[2] := 4;

  Work[3] := 5;   Work[4] := 7;

  Work[5] := 6;   Work[6] := 12;

  Work[7] := 7;   Work[8] := 3;

  Work[9] := 9;   Work[10] := 7;

  Work[11] := 0;  Work[12] := 9;  

  Work[13] := 1;  Work[14] := 0;  

  Work[15] := 8;    

  m := 0;

  For k := 1 to 15 Do

    If Work[k] > 6 Then

      Begin

        m := m + 1;

      End;

  Writeln(m);

End.


№8 (Номер в базе opengia.com: Задание №1498BC . Номер в базе ComputerScienceForAll.ru: 3150)

В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1] – количество голосов, поданных за первого исполнителя, Dat[2] – за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 16

  Dat[2] := 20

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 21

  Dat[7] := 28

  Dat[8] := 12

  Dat[9] := 15

  Dat[10] := 35

  m := 0

  нц для k от 1 до 10

    если Dat[k]>m то

     m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 16: Dat(2) = 20

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 21

Dat(7) = 28: Dat(8) = 12

Dat(9) = 15:Dat(10) = 35

m = 0 

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 16; Dat[2] := 20;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 21;

 Dat[7] := 28; Dat[8] := 12;

 Dat[9] := 15; Dat[10] := 35;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


№9 (Номер в базе opengia.com: Задание №14F9B6 . Номер в базе ComputerScienceForAll.ru: 3154)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т.д.). Определите число, которое будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1]:=7; Dat[2]:=9

  Dat[3]:=10; Dat[4]:=5

  Dat[5]:=6; Dat[6]:=7

  Dat[7]:=9; Dat[8]:=8

  Dat[9]:=6; Dat[10]:=9

  m:=10;n=0

  нц для k от 1 до 10

    если Dat[k] <= m  то

     m:=Dat[k];n:=k

    все

  кц

  вывод m

кон

 

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1)=7:  Dat(2)=9

Dat(3)=10: Dat(4)=5

Dat(5)=6:  Dat(6)=7

Dat(7)=9:  Dat(8)=8

Dat(9)=6:  Dat(10)=9

m = 10: n=0

FOR k = 1 TO 10

IF Dat(k) <= m THEN

m=Dat(k)

n=k

END IF

NEXT k

PRINT m

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 10; n := 0;

  for k := 1 to 10 do

    if  Dat[k] <= m then

      begin

        m := Dat[k]; n := k

      end;

  writeln(m);

End.


№10 (Номер в базе opengia.com: Задание №1579EC . Номер в базе ComputerScienceForAll.ru: 3157)

В таблице Dat представлены данные о количестве голосов, поданных за
10 исполнителей народных песен (Dat[1] – количество голосов, поданных за первого исполнителя, Dat[2] – за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 56

  Dat[2] := 70

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 22

  Dat[7] := 30

  Dat[8] := 12

  Dat[9] := 65

  Dat[10] := 35

  m := 0

  нц для k от 1 до 10

    если Dat[k]<35 то

     m := m+1

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65:Dat(10) = 35

m = 0 

FOR k = 1 TO 10

IF Dat(k)<35 THEN

m = m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 56; Dat[2] := 70;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 22;

 Dat[7] := 30; Dat[8] := 12;

 Dat[9] := 65; Dat[10] := 35;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]<35 then

     begin

       m := m+1

     end;

 writeln(m);

End.


№11 (Номер в базе opengia.com: Задание №1c5206 . Номер в базе ComputerScienceForAll.ru: 3209)

В таблице Ball хранятся баллы, набранные участниками школьного тура олимпиады по математике (Ball[1] – балл 1 ученика, Ball[2] – балл 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

    алг

    нач

        целтаб Ball[1:10]

        цел k, m

        Ball[1]:=42; Ball[2]:=25

        Ball[3]:=13; Ball[4]:=18

        Ball[5]:=15; Ball[6]:=55

        Ball[7]:=48; Ball[8]:=13

        Ball[9]:=64; Ball[10]:=45

        m := Ball[1]

        нц для k от 1 до 10

             если Ball[k] > m то

                  m := Ball[k]

             все

        кц

        вывод m

кон

DIM Ball(10) AS INTEGER

DIM k, m AS INTEGER

Ball(1)=42: Ball(2)=25

Ball(3)=13: Ball(4)=18

Ball(5)=15: Ball(6)=55

Ball(7)=48: Ball(8)=13

Ball(9)=64: Ball(10)=45

m := Ball(1)

FOR k = 1 TO 10

IF Ball(k) > m THEN

m := Ball(k)

END IF

NEXT k

PRINT m

Var k, m, t: integer;

Ball: array[1..10] of integer;

Begin

Ball[1]:=42; Ball[2]:=25;

Ball[3]:=13; Ball[4]:=18;

Ball[5]:=15; Ball[6]:=55;

Ball[7]:=48; Ball[8]:=13;

Ball[9]:=64; Ball[10]:=45;

m := Ball[1];

for k := 1 to 10 do

if Ball[k] > m then

m := Ball[k];

write(m);

End.


№12 (Номер в базе opengia.com: Задание №207062 . Номер в базе ComputerScienceForAll.ru: 3223)

В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах (Dat[1] – данные за понедельник, Dat[2] – за вторник и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  целтаб Dat[1:7]

  цел k, m

  Dat[1]:=–2; Dat[2]:=–1

  Dat[3]:=2; Dat[4]:=4

  Dat[5]:=0; Dat[6]:=–1

  Dat[7]:=–4

  m:= 0

  нц для k от 1 до 7

    если Dat[k] < 0 то

      m:=m+1

    все

  кц

  вывод m

кон

DIM Dat(7) AS INTEGER

Dat(1)=-2: Dat(2)=-1

Dat(3)=2: Dat(4)=4

Dat(5)=0: Dat(6)=-1

Dat(7)=-4

m = 0

FOR k = 1 TO 7

IF Dat(k) < 0 THEN

m=m+1 :

END IF

NEXT k

PRINT m

END

Var k, m: integer;

Dat: array[1..7] of integer;

Begin

  m:=0;

  Dat[1]:=-2; Dat[2]:=-1;

  Dat[3]:=2; Dat[4]:=4;

  Dat[5]:=0; Dat[6]:=-1;

  Dat[7]:=-4;

  for k:=1 to 7 do begin

    if Dat[k] < 0 then

      m:=m+1;

  end;

  write(m);

End.


№13 (Номер в базе opengia.com: Задание №221a2c . Номер в базе ComputerScienceForAll.ru: 3234)

В таблице Dat хранятся данные о количестве сделанных заданий учениками (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1]:=7; Dat[2]:=9

  Dat[3]:=10; Dat[4]:=5

  Dat[5]:=6; Dat[6]:=7

  Dat[7]:=9; Dat[8]:=8

  Dat[9]:=9; Dat[10]:=9

  m:=1;n=0

  нц для k от 1 до 10

    если Dat[k] > m  то

  m:=Dat[k];n:=k

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1)=7:  Dat(2)=9

Dat(3)=10: Dat(4)=5

Dat(5)=6:  Dat(6)=7

Dat(7)=9:  Dat(8)=8

Dat(9)=9:  Dat(10)=9

m = 1: n=0

FOR k = 1 TO 10

IF Dat(k) > m THEN

m=Dat(k)

n=k

ENDIF

NEXT k

PRINT n

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1]:=7;  Dat[2]:=9;

  Dat[3]:=10; Dat[4]:=5;

  Dat[5]:=6;  Dat[6]:=7;

  Dat[7]:=9;  Dat[8]:=8;

  Dat[9]:=9;  Dat[10]:=9;

  m:=1; n:=0;

  for k:=1 to 10 do

    if  Dat[k] > m then

      begin

        m:=Dat[k]; n:=k

      end;

  writeln(n)

End.


№14 (Номер в базе opengia.com: Задание №227eeb . Номер в базе ComputerScienceForAll.ru: 3239)

В таблице Work хранятся данные о количестве заказов, принятых фирмой «Алоэ» с первого по 15 ноября.  (Work[1] – число заказов, принятых 1 ноября, Work[2] – 2 ноября и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

    целтаб Work[1:15]

    цел k, m

    Work[1] := 5; Work[2] := 4

    Work[3] := 5; Work[4] := 7

    Work[5] := 6; Work[6] := 12

    Work[7] := 7; Work[8] := 3

    Work[9] := 9; Work[10] := 7

    Work[11] := 0;Work[12] := 9

    Work[13] := 1;Work[14] := 0

    Work[15] := 8

    m := 0

    нц для k от 1 до 15

        если Work[k] < 7 то

         m := m + 1

        все

    кц

    вывод m

кон

 

DIM Work(15) AS INTEGER

DIM k,m AS INTEGER

Work(1)= 5: Work(2)= 4

Work(3)= 5: Work(4) = 7

Work(5)= 6: Work(6)= 12

Work(7)= 7: Work(8)= 3

Work(9)= 9: Work(10)= 7

Work(11)= 0: Work(12)= 9

Work(13)= 1: Work(14)= 0

Work(15)= 8

m = 0

FOR k = 1 TO 15

IF Work(k) < 7 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

  Work: array[1..15] of integer;

Begin

  Work[1] := 5;   Work[2] := 4;

  Work[3] := 5;   Work[4] := 7;

  Work[5] := 6;   Work[6] := 12;

  Work[7] := 7;   Work[8] := 3;

  Work[9] := 9;   Work[10] := 7;

  Work[11] := 0;  Work[12] := 9;  

  Work[13] := 1;  Work[14] := 0;  

  Work[15] := 8;    

  m := 0;

  For k := 1 to 15 Do

    If Work[k] < 7 Then

      Begin

        m := m + 1;

      End;

  Writeln(m);

End.


№15 (Номер в базе opengia.com: Задание №260367 . Номер в базе ComputerScienceForAll.ru: 3259)

В таблице Dat хранятся данные о количестве сделанных заданий учениками (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  целтаб Dat[1:10]

  цел  k, n

  Dat[1]:=7; Dat[2]:=9

  Dat[3]:=10; Dat[4]:=5

  Dat[5]:=6; Dat[6]:=7

  Dat[7]:=9; Dat[8]:=8

  Dat[9]:=9; Dat[10]:=9

  n=0

  нц для k от 1 до 10

    если Dat[k] < 8  то

       n:=n+1

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, n AS INTEGER

Dat(1)=7:  Dat(2)=9

Dat(3)=10: Dat(4)=5

Dat(5)=6:  Dat(6)=7

Dat(7)=9:  Dat(8)=8

Dat(9)=9:  Dat(10)=9

n=0

FOR k = 1 TO 10

IF Dat(k) < 8 THEN

n=n+1

ENDIF

NEXT k

PRINT n

Var k, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1]:=7;  Dat[2]:=9;

  Dat[3]:=10; Dat[4]:=5;

  Dat[5]:=6;  Dat[6]:=7;

  Dat[7]:=9;  Dat[8]:=8;

  Dat[9]:=9;  Dat[10]:=9;

  n:=0;

  for k:=1 to 10 do

    if  Dat[k] < 8 then

      n:=n+1;

  writeln(n)

End.


№16 (Номер в базе opengia.com: Задание №266E39 . Номер в базе ComputerScienceForAll.ru: 3261)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 5; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 10; n := 0

  нц для k от 1 до 10

    если Dat[k] <= m  то

      m := Dat[k]

      n := k

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 5:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 10 : n = 0

FOR k = 1 TO 10

IF Dat(k) <= m THEN

m = Dat(k)

n = k

END IF

NEXT k

PRINT n

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 5;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 10; n := 0;

  for k := 1  to 10 do

    if  Dat[k] <= m then

      begin

        m := Dat[k]; n := k

      end;

  writeln(n)

End.


№17 (Номер в базе opengia.com: Задание №2C2506 . Номер в базе ComputerScienceForAll.ru: 3291)

В таблице Dat представлены данные о количестве голосов, поданных за
10 исполнителей народных песен (Dat[1] – количество голосов, поданных за первого исполнителя, Dat[2] – за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 56

  Dat[2] := 70

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 22

  Dat[7] := 30

  Dat[8] := 12

  Dat[9] := 65

  Dat[10] := 35

  m := 0

  нц для k от 1 до 10

    если Dat[k]>25 то

     m := m+1

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65:Dat(10) = 35

m = 0 

FOR k = 1 TO 10

IF Dat(k)>25 THEN

m = m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 56; Dat[2] := 70;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 22;

 Dat[7] := 30; Dat[8] := 12;

 Dat[9] := 65; Dat[10] := 35;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>25 then

     begin

       m := m+1

     end;

 writeln(m);

End.


№18 (Номер в базе opengia.com: Задание №2a0049 . Номер в базе ComputerScienceForAll.ru: 3310)

В таблице Ani хранятся данные о численности обезьян в зоопарке города Тулы (Ani[1] – число обезьян в 2001 году, Ani[2] – в 2002 и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

    целтаб Ani[1:12]

    цел k, m

    Ani[1] := 17; Ani[2] := 17

    Ani[3] := 19; Ani[4] := 21

    Ani[5] := 23; Ani[6] := 22

    Ani[7] := 24; Ani[8] := 16

    Ani[9] := 19; Ani[10] := 21

    Ani[11] := 17; Ani[12] :=17;

    m := 0

    нц для k от 1 до 12

        если Ani[k] = 17 то

         m := m + Ani[k]

        все

    кц

    вывод m

кон

DIM Ani(12) AS INTEGER

DIM k,m AS INTEGER

Ani(1)= 17: Ani(2)= 17

Ani(3)= 19: Ani(4) = 21

Ani(5)= 23: Ani(6)= 22

Ani(7)= 24: Ani(8)= 16

Ani(9)= 19: Ani(10)= 21

Ani(11)= 17: Ani(12)=17

m = 0

FOR k = 1 TO 12

IF Ani(k) = 17 THEN

m = m + Ani[k]

END IF

NEXT k

PRINT m

Var k, m: integer;

  Ani: array[1..12] of integer;

Begin

  Ani[1] := 17;  Ani[2] := 17;

  Ani[3] := 19;  Ani[4] := 21;

  Ani[5] := 23;  Ani[6] := 22;

  Ani[7] := 24;  Ani[8] := 16;

  Ani[9] := 19;  Ani[10] := 21;

  Ani[11] := 17;  Ani[12] :=17;

  m := 0;

  For k := 1 to 12 Do

    If Ani[k] = 17 Then

      Begin

        m := m + Ani[k];

      End;

  Writeln(m);

End.


№19 (Номер в базе opengia.com: Задание №2c7295 . Номер в базе ComputerScienceForAll.ru: 3315)

В таблице Ball хранятся отметки по контрольной работе (Ball[1] – отметка 1 ученика, Ball[2] – отметка 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  целтаб Ball[1:10]

  цел k, c

  Ball[1]:=3; Ball[2]:=5

  Ball[3]:=3; Ball[4]:=2

  Ball[5]:=5; Ball[6]:=5

  Ball[7]:=4; Ball[8]:=3

  Ball[9]:=3; Ball[10]:=5

  c:= 0

  нц для k от 1 до 10

    если Ball[k] <4 то

      c:=c+1

    все

  кц

  вывод c

кон

DIM Ball(10) AS INTEGER

DIM k, c AS INTEGER

Ball(1)=3: Ball(2)=5

Ball(3)=3: Ball(4)=2

Ball(5)=5: Ball(6)=5

Ball(7)=4: Ball(8)=3

Ball(9)=3: Ball(10)=5

c = 0

FOR k = 1 TO 10

IF Ball(k)<4 THEN

c=c+1

ENDIF

NEXT k

PRINT c

END

 

Var k, c: integer;

Ball: array[1..10] of integer;

Begin

  c:=0;

  Ball[1]:=3; Ball[2]:=5;

  Ball[3]:=3; Ball[4]:=2;

  Ball[5]:=5; Ball[6]:=5;

  Ball[7]:=4; Ball[8]:=3;

  Ball[9]:=3; Ball[10]:=5;

  for k:=1 to 10 do begin

    if Ball[k]<4 then

      c:=c+1;

  end;

  write(c);

End.


№20 (Номер в базе opengia.com: Задание №322772 . Номер в базе ComputerScienceForAll.ru: 3331)

В таблице Dat хранятся данные о количестве сделанных заданий учениками (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7

  Dat[2] := 9

  Dat[3] := 10

  Dat[4] := 5

  Dat[5] := 6

  Dat[6] := 7

  Dat[7] := 9

  Dat[8] := 8

  Dat[9] := 6

  Dat[10] := 9

  m := 10; n := 0

  нц для k от 1 до 10

    если Dat[k] < m то

      m := Dat[k]

      n := k

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7

Dat(2) = 9

Dat(3) = 10

Dat(4) = 5

Dat(5) = 6

Dat(6) = 7

Dat(7) = 9

Dat(8) = 8

Dat(9) = 6

Dat(10) = 9

m = 10: n = 0

FOR k = 1 TO 10

IF Dat(k) < m THEN

m = Dat(k)

n = k

ENDIF

NEXT k

PRINT n

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;

  Dat[2] := 9;

  Dat[3] := 10;

  Dat[4] := 5;

  Dat[5] := 6;

  Dat[6] := 7;

  Dat[7] := 9;

  Dat[8] := 8;

  Dat[9] := 6;

  Dat[10] := 9;

  m := 10; n := 0;

  for k := 1 to 10 do

    if  Dat[k] < m then

      begin

        m := Dat[k];

        n := k

      end;

  writeln(n)

End.


№21 (Номер в базе opengia.com: Задание №348fd9 . Номер в базе ComputerScienceForAll.ru: 3344)

В таблице Ball хранятся баллы, набранные участниками школьного тура олимпиады по математике (Ball[1] – балл 1 ученика, Ball[2] – балл 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

    целтаб Ball[1:10]

    цел k, m, t

    Ball[1]:=12; Ball[2]:=25

    Ball[3]:=13; Ball[4]:=18

    Ball[5]:=35; Ball[6]:=55

    Ball[7]:=48; Ball[8]:=33

    Ball[9]:=64; Ball[10]:=45

    m := Ball[1]; t := 1

    нц для k от 1 до 10

         если Ball[k] > m то

               m := Ball[k]; t := k

         все

    кц

    вывод t

кон

 

DIM Ball(10) AS INTEGER

DIM k, m, t AS INTEGER

Ball(1)=12: Ball(2)=25

Ball(3)=13: Ball(4)=18

Ball(5)=35: Ball(6)=55

Ball(7)=48: Ball(8)=33

Ball(9)=64: Ball(10)=45

m = Ball(1): t = 1

FOR k = 1 TO 10

    IF Ball(k) > m THEN

         m = Ball(k): t = k

    END IF

NEXT k

PRINT t

Var k, m, t: integer;

Ball: array[1..10] of integer;

Begin

Ball[1]:=12; Ball[2]:=25;

Ball[3]:=13; Ball[4]:=18;

Ball[5]:=35; Ball[6]:=55;

Ball[7]:=48; Ball[8]:=33;

Ball[9]:=64; Ball[10]:=45;

m := Ball[1]; t := 1;

for k := 1 to 10 do

if Ball[k] > m then begin

m := Ball[k]; t := k

end;

write(t);

End.


№22 (Номер в базе opengia.com: Задание №38E52C . Номер в базе ComputerScienceForAll.ru: 3364)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 10

  Dat[9] := 6; Dat[10] := 9

  m := 0 ; n := 0

  нц для k от 1 до 10

    если Dat[k] >= m  то

      m := Dat[k]

      n := k

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 10

Dat(9) = 6:  Dat(10) = 9

m = 0 : n =0

FOR k = 1 TO 10

IF Dat(k) >= m THEN

m = Dat(k)

n = k

END IF

NEXT k

PRINT n

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 10;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0; n := 0;

  for k := 1  to 10 do

    if  Dat[k] >= m then

      begin

        m := Dat[k]; n := k

      end;

  writeln(n)

End.


№23 (Номер в базе opengia.com: Задание №3B6137 . Номер в базе ComputerScienceForAll.ru: 3375)

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 12

  Dat[2] := 15

  Dat[3] := 17

  Dat[4] := 15

  Dat[5] := 14

  Dat[6] := 12

  Dat[7] := 10

  Dat[8] := 13

  Dat[9] := 14

  Dat[10] := 15

  m := 0

  нц для k от 1 до 10

    если Dat[k]=15 то

     m := m+1

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 0 

FOR k = 1 TO 10

IF Dat(k)=15 THEN

m = m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 12; Dat[2] := 15;

 Dat[3] := 17; Dat[4] := 15;

 Dat[5] := 14; Dat[6] := 12;

 Dat[7] := 10; Dat[8] := 13;

 Dat[9] := 14; Dat[10] := 15;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]=15 then

     begin

       m := m+1

     end;

 writeln(m);

End.


№24 (Номер в базе opengia.com: Задание №3a31a2 . Номер в базе ComputerScienceForAll.ru: 3396)

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] – количество учеников в первом классе, Dat[2] – во втором и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1]:=20; Dat[2]:=25

  Dat[3]:=19; Dat[4]:=25

  Dat[5]:=26; Dat[6]:=22

  Dat[7]:=24; Dat[8]:=28

  Dat[9]:=26; Dat[10]:=21

  Dat[11]:=27

  m:=0

  нц для k от 1 до 11

    если Dat[k] > m  то

       m:= Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1)=20: Dat(2)=25

Dat(3)=19: Dat(4)=25

Dat(5)=26: Dat(6)=22

Dat(7)=24: Dat(8)=28

Dat(9)=26: Dat(10)=21

Dat(11)=27

m = 0 

FOR k = 1 TO 11

IF Dat(k) > m THEN

m= Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..11] of integer;

Begin

  Dat[1]:=20;  Dat[2]:=25;

  Dat[3]:=19;  Dat[4]:=25;

  Dat[5]:=26;  Dat[6]:=22;

  Dat[7]:=24;  Dat[8]:=28;

  Dat[9]:=26;  Dat[10]:=21;

  Dat[11]:=27;

  m:=0;

  for k:=1 to 11 do

    if  Dat[k] > m then

       m:= Dat[k];

  writeln(m)

End.


№25 (Номер в базе opengia.com: Задание №3a3253 . Номер в базе ComputerScienceForAll.ru: 3397)

В таблице Dat хранятся данные измерений роста учеников 4 класса в сантиметрах. (Dat[1] – рост первого ученика, Dat[2] – второго и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

целтаб Dat[1:10]

цел  k, n, d

Dat[1] := 140; Dat[2] := 130

Dat[3] := 135; Dat[4] := 150

Dat[5] := 120;  Dat[6] := 150

Dat[7] := 110; Dat[8] := 140

Dat[9] := 150; Dat[10] := 135

n := 1; d := Dat[1]

нц для k от 2 до 10

если Dat[k] >= d то

d := Dat[k]; n := k

все

кц

вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, n, d AS INTEGER

Dat(1) = 140: Dat(2) = 130

Dat(3) = 135: Dat(4) = 150

Dat(5) = 120: Dat(6) = 150

Dat(7) = 110: Dat(8) = 140

Dat(9) = 150: Dat(10) = 135

n = 1: d = Dat(1)

FOR k = 2 TO 10

IF Dat(k) >= d THEN

d = Dat(k)

n = k

END IF

NEXT k

PRINT n

var k, n, d: integer;

Dat: array[1..10] of integer;

begin

Dat[1] := 140;  Dat[2] := 130;

Dat[3] := 135; Dat[4] := 150;

Dat[5] := 120;  Dat[6] := 150;

Dat[7] := 110; Dat[8] := 140;

Dat[9] := 150; Dat[10] := 135;

n := 1; d := Dat[1];

for k := 2 to 10 do

  begin

  if  Dat[k] >= d then

    begin

      d := Dat[k]; n := k

    end;

  end;

write(n);

end.


№26 (Номер в базе opengia.com: Задание №463E27 . Номер в базе ComputerScienceForAll.ru: 3439)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 0

  нц для k от 1 до 10

    если Dat[k] > m  то

     m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 0 

FOR k = 1 TO 10

IF Dat(k) > m THEN

m = Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0;

  for k := 1  to 10 do

    if  Dat[k] > m then

      begin

        m := Dat[k]

      end;

  writeln(m)

End.


№27 (Номер в базе opengia.com: Задание №46EEBC . Номер в базе ComputerScienceForAll.ru: 3442)

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 12

  Dat[2] := 15

  Dat[3] := 17

  Dat[4] := 15

  Dat[5] := 14

  Dat[6] := 12

  Dat[7] := 10

  Dat[8] := 13

  Dat[9] := 14

  Dat[10] := 15

  m := 0

  нц для k от 1 до 10

    если Dat[k]>m  то

     m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 0 

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 12; Dat[2] := 15;

 Dat[3] := 17; Dat[4] := 15;

 Dat[5] := 14; Dat[6] := 12;

 Dat[7] := 10; Dat[8] := 13;

 Dat[9] := 14; Dat[10] := 15;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


№28 (Номер в базе opengia.com: Задание №484f32 . Номер в базе ComputerScienceForAll.ru: 3449)

В таблице A хранятся данные о количестве учеников, опоздавших на занятия, за неделю (A[1] – данные за понедельник, A[2] – за вторник и т. д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  цел таб A[1:6]

  цел k, m, day

  A[1]:= 3; A[2]:= 1

  A[3]:= 4; A[4]:= 2

  A[5]:= 4; A[6]:= 2

  day := 1; m := A[1]

  нц для k от 2 до 6

    если A[k] >= m то

    m := A[k]; day := k

    все

  кц

  вывод day

кон

DIM day, m, k AS INTEGER

DIM A(6) AS INTEGER

A(1)=3: A(2)=1

A(3)=4: A(4)=2

A(5)=4: A(6)=2

day = 1: m = A(1)

FOR k = 2 TO 6

IF A(k) >= m THEN

m = A(k)

day = k

END IF

NEXT k

PRINT day

var k, m, day: integer;

A: array[1..6] of integer;

Begin

  A[1]:= 3; A[2]:= 3;

  A[3]:= 4; A[4]:= 2;

  A[5]:= 4; A[6]:= 2;

  day := 1; m := A[1];

  for k := 2 to 6 do

    begin

      if A[k] >= m then

         begin

           m := A[k];

           day := k;

         end;

    end;

  write(day);

end.


№29 (Номер в базе opengia.com: Задание №4C91A4 . Номер в базе ComputerScienceForAll.ru: 3475)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 7

m = 0 

FOR k = 1 TO 10

IF Dat(k) < 8 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 7;

  m := 0;

  for k := 1  to 10 do

    if  Dat[k] < 8 then

      begin

        m := m + 1

      end;

  writeln(m)

End.


№30 (Номер в базе opengia.com: Задание №4E071F . Номер в базе ComputerScienceForAll.ru: 3481)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF k < 5 THEN

m = m + Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1  to 11 do

    if  k< 5 then

      begin

        m := m + Dat[k]

      end;

  writeln(m)

End.


№31 (Номер в базе opengia.com: Задание №4F1EB1 . Номер в базе ComputerScienceForAll.ru: 3490)

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй
и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 2

  Dat[2] := 5

  Dat[3] := 7

  Dat[4] := 5

  Dat[5] := 4

  Dat[6] := 2

  Dat[7] := 0

  Dat[8] := 2

  Dat[9] := 4

  Dat[10] := 5

  m := 0

  нц для k от 1 до 10

    если Dat[k]>3 то

     m := m+1

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 2: Dat(2) = 5

Dat(3) = 7: Dat(4) = 5

Dat(5) = 4: Dat(6) = 2

Dat(7) = 0: Dat(8) = 2

Dat(9) = 4:Dat(10) = 5

m = 0 

FOR k = 1 TO 10

IF Dat(k)>3 THEN

m = m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 2; Dat[2] := 5;

 Dat[3] := 7; Dat[4] := 5;

 Dat[5] := 4; Dat[6] := 2;

 Dat[7] := 0; Dat[8] := 2;

 Dat[9] := 4; Dat[10] := 5;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>3 then

     begin

       m := m+1

     end;

 writeln(m);

End.


№32 (Номер в базе opengia.com: Задание №506349 . Номер в базе ComputerScienceForAll.ru: 3503)

В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах (Dat[1] – данные за понедельник, Dat[2] – за вторник и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:7]

  цел k, m

  Dat[1]:=15; Dat[2]:=18

  Dat[3]:=22; Dat[4]:=20

  Dat[5]:=23; Dat[6]:=24

  Dat[7]:=20

  m:= 0

  нц для k от 1 до 7

    если Dat[k] >20 то

      m:=m+1

    все

  кц

  вывод m

кон

 

Бейсик

DIM Dat(7) AS INTEGER

Dat(1)=15: Dat(2)=18

Dat(3)=22: Dat(4)=20

Dat(5)=23: Dat(6)=24

Dat(7)=20

m = 0

FOR k = 1 TO 7

IF Dat(k) >20 THEN

m=m+1 :

END IF

NEXT k

PRINT m

END

 

Паскаль

Var k, m: integer;

Dat: array[1..7] of integer;

Begin

  m:=0;

  Dat[1]:=15; Dat[2]:=18;

  Dat[3]:=22; Dat[4]:=20;

  Dat[5]:=23; Dat[6]:=24;

  Dat[7]:=20;

  for k:=1 to 7 do begin

    if Dat[k] >20 then

      m:=m+1;

  end;

  write(m);

End.


№33 (Номер в базе opengia.com: Задание №54A58E . Номер в базе ComputerScienceForAll.ru: 3529)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т.д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 0

  нц для k от 1 до 10

    если Dat[k] > 7  то

     m := m + Dat[k]

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 0 

FOR k = 1 TO 10

IF Dat(k) > 7 THEN

m = m + Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0;

  for k := 1  to 10 do

    if  Dat[k] > 7 then

      m := m + Dat[k];

  writeln(m)

End.


№34 (Номер в базе opengia.com: Задание №5B7916 . Номер в базе ComputerScienceForAll.ru: 3556)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 0

  нц для k от 1 до 10

    если Dat[k] >8  то

     m := m + Dat[k]

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 0 

FOR k = 1 TO 10

IF Dat(k) >8 THEN

m = m + Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0;

  for k := 1  to 10 do

    if  Dat[k] >8 then

      begin

        m := m + Dat[k]

      end;

  writeln(m)

End.


№35 (Номер в базе opengia.com: Задание №5E530A . Номер в базе ComputerScienceForAll.ru: 3566)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т.д.). Определите число, которое будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

         Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 10

  Dat[9] := 6; Dat[10] := 9

  m := 0; n = 0

  нц для k от 1 до 10

    если Dat[k] >= m  то

     m := Dat[k]; n := k

    все

  кц

  вывод m

кон

 

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 10

Dat(9) = 6:  Dat(10) = 9

m = 0: n = 0

FOR k = 1 TO 10

IF Dat(k) >= m THEN

m = Dat(k)

n = k

END IF

NEXT k

PRINT m

Var k, m, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 10;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0; n := 0;

  for k := 1 to 10 do

    if  Dat[k] >= m then

      begin

        m := Dat[k]; n := k

      end;

  writeln(m);

End.


№36 (Номер в базе opengia.com: Задание №5a93f6 . Номер в базе ComputerScienceForAll.ru: 3574)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмичекий

язык

алг

нач

  цел s,k

  s:= 0

  нц для k от 4 до 11

    s:=s + k

  кц

  вывод s

кон

Бейсик

dim s,k as integer

s  =  0

FOR k = 4 TO 11

s = s + k

NEXT k

PRINT   s

END

Паскаль

var s, k:integer;

begin

  s:= 0;

  for k:= 4 to 11 do

    s:= s + k;

  writeln (s);

end.              


№37 (Номер в базе opengia.com: Задание №5c2cbe . Номер в базе ComputerScienceForAll.ru: 3576)

В таблице A хранятся данные о количестве призеров олимпиады по программированию по 9-ти округам Москвы. Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмичекий

язык

алг

нач

  целтаб A[1:9]

  цел k, score

  A[1]:=9; A[2]:=11

  A[3]:=7; A[4]:=12

  A[5]:=13; A[6]:=5

  A[7]:=9; A[8]:=3

  A[9]:=4

  score:= 0

  нц для k от 1 до 9

    если A[k] < 9 то

    score:=score+A[k]

    все

  кц

  вывод score

кон

Бейсик

DIM A(9) AS INTEGER

DIM k, score AS INTEGER

A(1)=9: A(2)=11

A(3)=7: A(4)=12

A(5)=13: A(6)=5

A(7):=9: A(8):=3

A(9):=4

score=0

FOR k = 1 TO 9

IF A(k) < 9 THEN

score=score+A(k)

END IF

NEXT k

PRINT score

END

Паскаль

var k, score: integer;

A: array[1..9] of integer;

begin

  A[1]:=9; A[2]:=11;

  A[3]:=7; A[4]:=12;

  A[5]:=13; A[6]:=5;

  A[7]:=9; A[8]:=3;

  A[9]:=4;

  score:= 0;

  for k:=1 to 9 do

    begin

      if A[k] < 9 then

         score:=score+A[k];

     end;

  write(score);

end.


№38 (Номер в базе opengia.com: Задание №5e7c22 . Номер в базе ComputerScienceForAll.ru: 3582)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический

язык

алг

нач

  цел s,k

  s:=1

  нц для k от 1 до 7

    s:= s + k

  кц

  вывод s

кон

Бейсик

DIM s,k AS INTEGER

s  =  1

FOR k =1 TO 7

s = s + k

NEXT k

PRINT   s

END

Паскаль

var s, k:integer;

begin

  s:= 1;

  for k:= 1 to 7 do

    s:= s + k;

  writeln (s);

end.


№39 (Номер в базе opengia.com: Задание №603d2f . Номер в базе ComputerScienceForAll.ru: 3585)

Школьница делала лабораторную работу по физике, в ходе которой измерила 10 раз силу тока и записала показания амперметра в таблицу Tok (Tok[1] – результат первого измерения, Tok[2] – второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

    целтаб Tok[1:10]

    цел k, m

    Tok[1] := 10; Tok[2] := 14

    Tok[3] := 15; Tok[4] := 4

    Tok[5] := 12; Tok[6] := 6

    Tok[7] := 3; Tok[8] := 5

    Tok[9] := 5; Tok[10] := 10

    m := 0

    нц для k от 1 до 10

        если Tok[k] > 6 то

         m := m + 2

        все

    кц

    вывод m

кон

Бейсик

DIM Tok(10) AS INTEGER

DIM k,m AS INTEGER

Tok(1)= 10:  Tok(2)= 14

Tok(3)= 15:  Tok(4) = 4

Tok(5)= 12:  Tok(6)= 6

Tok(7)= 3:  Tok(8)= 5

Tok(9)= 5:  Tok(10)= 10

m = 0

FOR k = 1 TO 10

IF Tok(k) > 6 THEN

m = m + 2

END IF

NEXT k

PRINT m

Паскаль

Var k, m: integer;

  Tok: array[1..10] of integer;

Begin

  Tok[1] := 10;   Tok[2] := 14;

  Tok[3] := 15;   Tok[4] := 4;

  Tok[5] := 12;   Tok[6] := 6;

  Tok[7] := 3;   Tok[8] := 5;

  Tok[9] := 5;   Tok[10] := 10;

  m := 0;

  For k := 1 to 10 Do

    If Tok[k] > 6 Then

      Begin

        m := m + 2;

      End;

  Writeln(m);

End.


№40 (Номер в базе opengia.com: Задание №61E992 . Номер в базе ComputerScienceForAll.ru: 3593)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:11]

  цел  k, m, n

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 30

  нц для k от 1 до 11

    если Dat[k] < m  то

      m := Dat[k]

      n := k

    все

  кц

  вывод n

кон

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m,n AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 30 

FOR k = 1 TO 11

IF Dat(k) < m THEN

m = Dat(k)

n = k

END IF

NEXT k

PRINT n

Var k, m, n : integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 30;

  for k := 1  to 11 do

    if  Dat[k] < m then

      begin

        m: = Dat[k];

        n: = k

      end;

  writeln(n)

End.


№41 (Номер в базе opengia.com: Задание №6432bd . Номер в базе ComputerScienceForAll.ru: 3607)

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] – количество учеников в первом классе, Dat[2] – во втором и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1]:=20; Dat[2]:=25

  Dat[3]:=19; Dat[4]:=25

  Dat[5]:=26; Dat[6]:=22

  Dat[7]:=24; Dat[8]:=28

  Dat[9]:=26; Dat[10]:=21

  Dat[11]:=27

  m:=30

  нц для k от 1 до 11

    если Dat[k] < m  то

       m:= Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1)=20: Dat(2)=25

Dat(3)=19: Dat(4)=25

Dat(5)=26: Dat(6)=22

Dat(7)=24: Dat(8)=28

Dat(9)=26: Dat(10)=21

Dat(11)=27

m = 30 

FOR k = 1 TO 11

IF Dat(k) < m THEN

m= Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..11] of integer;

Begin

  Dat[1]:=20;  Dat[2]:=25;

  Dat[3]:=19;  Dat[4]:=25;

  Dat[5]:=26;  Dat[6]:=22;

  Dat[7]:=24;  Dat[8]:=28;

  Dat[9]:=26;  Dat[10]:=21;

  Dat[11]:=27;

  m:=30;

  for k:=1 to 11 do

    if  Dat[k] < m then

       m:= Dat[k];

  writeln(m)

End.


№42 (Номер в базе opengia.com: Задание №643af6 . Номер в базе ComputerScienceForAll.ru: 3609)

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трех языках программирования.

Алгоритмический язык

алг

нач

  цел s, k

  s:=1

  нц для k от 3 до 6

    s:=s * k

  кц

  вывод s

кон

Бейсик

DIM s, k AS INTEGER

s = 1

FOR k = 3 TO 6

 s = s * k

NEXT k

PRINT s

END

Паскаль

Var s,k: integer;

Begin

 s:=1;

 for k:=3 to 6 do

   s:=s * k;

 write(s);

End.


№43 (Номер в базе opengia.com: Задание №6683e2 . Номер в базе ComputerScienceForAll.ru: 3626)

Сотрудник метеобюро в ходе измерений среднесуточной температуры записывал показания термометра в таблицу Tem.  (Tem[1] – температура, полученная в результате первого измерения, Tem[2] – второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

алг

нач

   целтаб Tem[1:12]

   цел k, b

   b := 0

   Tem[1] := 22; Tem[2] := 25

   Tem[3] := 20; Tem[4] := 18

   Tem[5] := 16; Tem[6] := 14

   Tem[7] := 20; Tem[8] := 23

   Tem[9] := 17; Tem[10] := 19

   Tem[11] := 20; Tem[12] := 21

   нц для k от 1 до 12

      если Tem[k] < 19 то

        b := b + Tem[k]

       все

   кц

   вывод b

кон

DIM Tem(12) AS INTEGER

DIM k,b AS INTEGER

b = 0

Tem(1)= 22:  Tem(2)= 25

Tem(3)= 20:  Tem(4) = 18

Tem(5)= 16:  Tem(6)= 14

Tem(7)= 20:  Tem(8)= 23

Tem(9)= 17:  Tem(10)= 19

Tem(11)= 20:  Tem(12)= 21

FOR k = 1 TO 12

IF Tem(k) < 19 THEN

b = b + Tem[k]

END IF

NEXT k

PRINT b

Паскаль

Var k, b: integer;

  Tem: array[1..12] of integer;

Begin

  b := 0;

  Tem[1] := 22;   Tem[2] := 25;

  Tem[3] := 20;   Tem[4] := 18;

  Tem[5] := 16;   Tem[6] := 14;

  Tem[7] := 20;   Tem[8] := 23;

  Tem[9] := 17;   Tem[10] := 19;

  Tem[11] := 20;   Tem[12] := 21;

  For k := 1 to 12 Do

    If Tem[k] < 19 Then

        b := b + Tem[k];

  Writeln(b);

End.


№44 (Номер в базе opengia.com: Задание №66fc6a . Номер в базе ComputerScienceForAll.ru: 3634)

В таблице Sea хранятся данные о количестве россиян, отдыхавших на Чёрном море (Sea[1] – число россиян в 2001 году, Sea[2] – в 2002 и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический язык

алг

нач

    целтаб Sea[1:12]

    цел k, s

    Sea[1] := 170; Sea[2] := 170

    Sea[3] := 190; Sea[4] := 210

    Sea[5] := 230; Sea[6] := 220

    Sea[7] := 240; Sea[8] := 160

    Sea[9] := 190; Sea[10] := 210

    Sea[11] := 170; Sea[12] :=170

    s := 100

    нц для k от 1 до 12

        если Sea[k] > 220 то

         s := s + Sea[k]

        все

    кц

    вывод s

кон

 

Бейсик

DIM Sea(12) AS INTEGER

DIM k,s AS INTEGER

Sea(1)= 170: Sea(2)= 170

Sea(3)= 190: Sea(4) = 210

Sea(5)= 230: Sea(6)= 220

Sea(7)= 240: Sea(8)= 160

Sea(9)= 190: Sea(10)= 210

Sea(11)= 170: Sea(12)=170

s = 100

FOR k = 1 TO 12

IF Sea(k) > 220 THEN

s = s +Sea(k)

END IF

NEXT k

PRINT s

 

Паскаль

Var k, s: integer;

  Sea: array[1..12] of integer;

Begin

  Sea[1] := 170; Sea[2] := 170;

  Sea[3] := 190; Sea[4] := 210;

  Sea[5] := 230; Sea[6] := 220;

  Sea[7] := 240; Sea[8] := 160;

  Sea[9] := 190; Sea[10] := 210;

  Sea[11] := 170; Sea[12] :=170;

  s := 100;

  For k := 1 to 12 do

    If Sea[k] > 220 Then

      Begin

       s := s + Sea[k];

      End;

  Writeln(s);

End.


№45 (Номер в базе opengia.com: Задание №68c459 . Номер в базе ComputerScienceForAll.ru: 3646)

В таблице Tur хранятся данные о количестве ребят, ходивших в поход вместе с туристическим клубом "Сказка". (Tur[1] – число ребят в 2001 году, Tur[2] – в 2002 и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

    целтаб Tur[1:11]

    цел k, m

    Tur[1] := 1; Tur[2] := 11

    Tur[3] := 8; Tur[4] := 12

    Tur[5] := 5; Tur[6] := 6

    Tur[7] := 15; Tur[8] := 16

    Tur[9] := 16; Tur[10] := 21

    Tur[11] := 7;

    m := 0

    нц для k от 1 до 11

        если Tur[k] > 12 то

         m := m + Tur[k]

        все

    кц

    вывод m

кон

Бейсик

DIM Tur(11) AS INTEGER

DIM k,m AS INTEGER

Tur(1)= 1: Tur(2)= 11

Tur(3)= 8: Tur(4) = 12

Tur(5)= 5: Tur(6)= 6

Tur(7)= 15: Tur(8)= 16

Tur(9)= 16: Tur(10)= 21

Tur(11)= 7

m = 0

FOR k = 1 TO 11

IF Tur(k) > 12 THEN

m = m + Tur(k)

END IF

NEXT k

PRINT m

Паскаль

Var k, m: integer;

  Tur: array[1..11] of integer;

Begin

  Tur[1] := 1;   Tur[2] := 11;

  Tur[3] := 8;  Tur[4] := 12;

  Tur[5] := 5;   Tur[6] := 6;

  Tur[7] := 15;  Tur[8] := 16;

  Tur[9] := 16;   Tur[10] := 21;

  Tur[11] := 7;  

  m := 0;

  For k := 1 to 11 Do

    If Tur[k] > 12 Then

      Begin

        m := m + Tur[k];

      End;

  Writeln(m);

End.


№46 (Номер в базе opengia.com: Задание №6ED4CF . Номер в базе ComputerScienceForAll.ru: 3675)

В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1] – количество голосов, поданных за первого исполнителя, Dat[2] – за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 16

  Dat[2] := 20

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 21

  Dat[7] := 28

  Dat[8] := 11

  Dat[9] := 15

  Dat[10] := 35

  m := 50

  нц для k от 1 до 10

    если Dat[k]<m то

     m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 16: Dat(2) = 20

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 21

Dat(7) = 28: Dat(8) = 11

Dat(9) = 15:Dat(10) = 35

m = 50 

FOR k = 1 TO 10

IF Dat(k)<m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 16; Dat[2] := 20;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 21;

 Dat[7] := 28; Dat[8] := 11;

 Dat[9] := 15; Dat[10] := 35;

 m := 50;

 for k := 1 to 10 do

   if  Dat[k]<m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


№47 (Номер в базе opengia.com: Задание №6a0387 . Номер в базе ComputerScienceForAll.ru: 3680)

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] – количество учеников в первом классе, Dat[2] – во втором и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1]:=20; Dat[2]:=25

  Dat[3]:=19; Dat[4]:=25

  Dat[5]:=26; Dat[6]:=22

  Dat[7]:=24; Dat[8]:=28

  Dat[9]:=26; Dat[10]:=21

  Dat[11]:=27

  m:=0

  нц для k от 1 до 11

    если Dat[k] > 24  то

m:=m+1

    все

  кц

  вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1)=20: Dat(2)=25

Dat(3)=19: Dat(4)=25

Dat(5)=26: Dat(6)=22

Dat(7)=24: Dat(8)=28

Dat(9)=26: Dat(10)=21

Dat(11)=27

m = 0 

FOR k = 1 TO 11

IF Dat(k) > 24 THEN

m=m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..11] of integer;

Begin

  Dat[1]:=20;  Dat[2]:=25;

  Dat[3]:=19;  Dat[4]:=25;

  Dat[5]:=26;  Dat[6]:=22;

  Dat[7]:=24;  Dat[8]:=28;

  Dat[9]:=26;  Dat[10]:=21;

  Dat[11]:=27;

  m:=0;

  for k:=1 to 11 do

    if  Dat[k] > 24 then

        m:=m+1;

  writeln(m)

End.


№48 (Номер в базе opengia.com: Задание №6aeb17 . Номер в базе ComputerScienceForAll.ru: 3684)

Школьник делал лабораторную работу по физике, в ходе которой измерил 10 раз силу тока и записал показания амперметра в таблицу Tok (Tok[1] – результат первого измерения, Tok[2] – второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

    целтаб Tok[1:10]

    цел k, m

    Tok[1] := 10; Tok[2] := 14

    Tok[3] := 15; Tok[4] := 4

    Tok[5] := 12; Tok[6] := 6

    Tok[7] := 3; Tok[8] := 5

    Tok[9] := 5; Tok[10] := 10

    m := 22

    нц для k от 1 до 10

        если Tok[k] > 10 то

         m := m — 1

        все

    кц

    вывод m

кон

Бейсик

DIM Tok(10) AS INTEGER

DIM k,m AS INTEGER

Tok(1)= 10:  Tok(2)= 14

Tok(3)= 15:  Tok(4) = 4

Tok(5)= 12:  Tok(6)= 6

Tok(7)= 3:  Tok(8)= 5

Tok(9)= 5:  Tok(10)= 10

m = 22

FOR k = 1 TO 10

IF Tok(k) > 10 THEN

m = m — 1

END IF

NEXT k

PRINT m

Паскаль

Var k, m: integer;

  Tok: array[1..10] of integer;

Begin

  Tok[1] := 10;   Tok[2] := 14;

  Tok[3] := 15;   Tok[4] := 4;

  Tok[5] := 12;   Tok[6] := 6;

  Tok[7] := 3;   Tok[8] := 5;

  Tok[9] := 5;   Tok[10] := 10;

  m := 22;

  For k := 1 to 10 Do

    If Tok[k] > 10 Then

      Begin

        m := m — 1;

      End;

  Writeln(m);

End.


№49 (Номер в базе opengia.com: Задание №6c2477 . Номер в базе ComputerScienceForAll.ru: 3685)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический

язык

алг

нач

  цел s,k

  s:=100

  нц для k от 0 до 10

    s:=s-5

  кц

  вывод s

кон

Бейсик

DIM s AS INTEGER

DIM k AS INTEGER

s  =  100

FOR k = 0 TO 10

s = s – 5

NEXT k

PRINT   s

END

Паскаль

var s, k:integer;

begin

  s:= 100;

  for k:= 0 to 10 do

  s:= s — 5;

  writeln (s);

end.


№50 (Номер в базе opengia.com: Задание №6c9321 . Номер в базе ComputerScienceForAll.ru: 3688)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

      цел  n, m

      m := 50,

      нц для n от 1 до 7

            m := m – 7

   кц

   вывод m

кон

Бейсик

m = 50

FOR n = 1 TO 7

      m = m 7

NEXT n

PRINT m

END

Паскаль

var m, n : integer;

begin

   m := 50;

   for n := 1 to 7 do

      m := m 7;

 write(m);

end.


№51 (Номер в базе opengia.com: Задание №70D6DF . Номер в базе ComputerScienceForAll.ru: 3699)

В таблице Pos хранятся данные о количестве посетителей школьного музея за семь дней (Pos[1] – данные за первый день, Pos[2] – за второй день и т.д.). Определите число, которое будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

 целтаб Pos[1:7]

 цел  k, m, day

 Pos[1] := 17

 Pos[2] := 19

 Pos[3] := 20

 Pos[4] := 18

 Pos[5] := 16

 Pos[6] := 20

 Pos[7] := 16

 day:= 1

 m:=Pos[1]

 нц для k от 2 до 7

  если Pos[k] > m то

    m:=Pos[k]

    day:=k

  все

 кц

 вывод day

кон

DIM Pos(7)AS INTEGER

 Pos(1) = 17

 Pos(2) = 19

 Pos(3) = 20

 Pos(4) = 18

 Pos(5) = 16

 Pos(6) = 20

 Pos(7) = 16

 day = 1

 m = Pos(1)

FOR k = 2 TO 7

 IF Pos(k) > m THEN

   m = Pos(k)

   day = k

 END IF

NEXT k

PRINT day

END

Var k, m, day: integer;

 Pos: array[1..7] of integer;

Begin

 Pos[1] := 17; 

 Pos[2] := 19;

 Pos[3] := 20;

 Pos[4] := 18;

 Pos[5] := 16; 

 Pos[6] := 20;

 Pos[7] := 16; 

 day := 1; m := Pos[1];

 for k:=2 to 7 do begin

   if  Pos[k] > m then

     begin

       m := Pos[k];

       day := k

     end

 end;

 write(day);

End.


№52 (Номер в базе opengia.com: Задание №70d827 . Номер в базе ComputerScienceForAll.ru: 3702)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 18 до 22

   s := s+12

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 18 TO 22

s = s+12

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 18 to 22 do

   s := s+12;

 writeln(s);

End.


№53 (Номер в базе opengia.com: Задание №712C0D . Номер в базе ComputerScienceForAll.ru: 3708)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m, n

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 10; n := 0

  нц для k от 1 до 10

    если Dat[k] < m  то

      m := Dat[k]

      n := k

    все

  кц

  вывод n

кон

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k, m, n AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 10: n = 0

FOR k = 1 TO 10

IF Dat(k) < m THEN

m = Dat(k)

n = k

END IF

NEXT k

PRINT n

Var k, m, n: integer;

 Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 10; n := 0;

  for k := 1  to 10 do

    if  Dat[k] < m then

      begin

        m := Dat[k]; n := k

      end;

  writeln(n)

End.


№54 (Номер в базе opengia.com: Задание №786089 . Номер в базе ComputerScienceForAll.ru: 3743)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический
язык

алг

нач

  цел s, k

  s := 0

  нц для k от 2 до 12

    s := s + 11

  кц

  вывод s

кон

Бейсик

DIM s, k AS INTEGER

s  =  0

FOR k = 2 TO 12

s = s + 11

NEXT k

PRINT s

Паскаль

var s, k:integer;

begin

  s := 0;

  for k := 2 to 12 do

  s := s + 11;

  writeln (s);

end.


№55 (Номер в базе opengia.com: Задание №7D4A49 . Номер в базе ComputerScienceForAll.ru: 3778)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 10

  нц для k от 1 до 10

    если Dat[k] < m  то

     m := Dat[k]

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 10 

FOR k = 1 TO 10

IF Dat(k) < m THEN

m = Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 10;

  for k := 1  to 10 do

    if  Dat[k] < m then

      begin

        m := Dat[k]

      end;

  writeln(m)

End.


№56 (Номер в базе opengia.com: Задание №7FA547 . Номер в базе ComputerScienceForAll.ru: 3788)

В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1] – количество голосов, поданных за первого исполнителя, Dat[2] – за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 16

  Dat[2] := 20

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 21

  Dat[7] := 28

  Dat[8] := 12

  Dat[9] := 15

  Dat[10] := 35

  m := 0

  нц для k от 1 до 10

    если Dat[k]<25 то

     m := m+1

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 16: Dat(2) = 20

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 21

Dat(7) = 28: Dat(8) = 12

Dat(9) = 15:Dat(10) = 35

m = 0 

FOR k = 1 TO 10

IF Dat(k)<25 THEN

m = m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 16; Dat[2] := 20;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 21;

 Dat[7] := 28; Dat[8] := 12;

 Dat[9] := 15; Dat[10] := 35;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]<25 then

     begin

       m := m+1

     end;

 writeln(m);

End.


№57 (Номер в базе opengia.com: Задание №7a01e9 . Номер в базе ComputerScienceForAll.ru: 3790)

В таблице A хранятся данные о количестве призеров олимпиады по программированию по 9-ти округам Москвы. Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический

язык

алг

нач

  целтаб A[1:9]

  цел k, score

  A[1]:=6; A[2]:=11

  A[3]:=7; A[4]:=12

  A[5]:=13; A[6]:=5

  A[7]:=9; A[8]:=3

  A[9]:=4

  score:= 0

  нц для k от 1 до 9

    если A[k] >= 9 то

    score:=score+A[k]

    все

  кц

  вывод score

кон

Бейсик

DIM A(9) AS INTEGER

DIM k, score AS INTEGER

A(1)=6: A(2)=11

A(3)=7: A(4)=12

A(5)=13: A(6)=5

A(7):=9: A(8):=3

A(9):=4

score=0

FOR k = 1 TO 9

IF A(k) >= 8 THEN

score=score+A(k)

END IF

NEXT k

PRINT score

END

Паскаль

var k, score: integer;

A: array[1..9] of integer;

begin

  A[1]:=6; A[2]:=11;

  A[3]:=7; A[4]:=12;

  A[5]:=13; A[6]:=5;

  A[7]:=9; A[8]:=3;

  A[9]:=4;

  score:= 0;

  for k:=1 to 9 do

    begin

      if A[k] >= 9 then

         score:= score+A[k];

     end;

  write(score);

end.


№58 (Номер в базе opengia.com: Задание №802783 . Номер в базе ComputerScienceForAll.ru: 3798)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 7,

 нц для k от 13 до 18

   s := s+9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 7

FOR k = 13 TO 18

s = s+9

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 7;

 for k := 13 to 18 do

   s := s+9;

 writeln(s);

End.


№59 (Номер в базе opengia.com: Задание №8277eb . Номер в базе ComputerScienceForAll.ru: 3810)

В таблице Ball хранятся отметки по контрольной работе (Ball[1] – отметка 1 ученика, Ball[2] – отметка 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

  нач
  целтаб Ball[1:10]
  цел k, c
  Ball[1]:=4; Ball[2]:=5
  Ball[3]:=3; Ball[4]:=4
  Ball[5]:=2; Ball[6]:=5
  Ball[7]:=4; Ball[8]:=3
  Ball[9]:=4

  Ball[10]:=5

  c:= 0
  нц для k от 1 до 10
   если Ball[k] >4 то
     c:=c+1
   все
  кц
  вывод c
кон

DIM Ball(10) AS INTEGER
DIM k, c AS INTEGER
Ball(1)=4: Ball(2)=5
Ball(3)=3: Ball(4)=4
Ball(5)=2: Ball(6)=5
Ball(7)=4: Ball(8)=3
Ball(9)=4: Ball(10)=5
c = 0
FOR k = 1 TO 10
IF Ball(k) >4 THEN
c=c+1
ENDIF
NEXT k
PRINT c
END

Var k, c: integer;
Ball:array[1..10] of integer;
Begin
  c:=0;
  Ball[1]:=4; Ball[2]:=5;
  Ball[3]:=3; Ball[4]:=4;
  Ball[5]:=2; Ball[6]:=5;
  Ball[7]:=4; Ball[8]:=3;
  Ball[9]:=4; Ball[10]:=5;
  for k:=1 to 10 do
    if Ball[k] >4 then
       c:=c+1;
  write(c);
End.


№60 (Номер в базе opengia.com: Задание №855D40 . Номер в базе ComputerScienceForAll.ru: 3830)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] > m  то

     m := Dat[k]

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF Dat(k) > m THEN

m = Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1  to 11 do

    if  Dat[k] > m then

      begin

        m := Dat[k]

      end;

  writeln(m)

End.


№61 (Номер в базе opengia.com: Задание №885b0a . Номер в базе ComputerScienceForAll.ru: 3851)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 17 до 21

   s := s+11

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 17 TO 21

s = s+11

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 17 to 21 do

   s := s+11;

 writeln(s);

End.


№62 (Номер в базе opengia.com: Задание №8a1c0c . Номер в базе ComputerScienceForAll.ru: 3883)

В таблице Dat хранятся отметки учащихся 9 класса за самостоятельную работу (Dat[1] – отметка первого учащегося, Dat[2] – второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

 алг

нач

  целтаб Dat[1:10]

  цел k, m

  Dat[1] := 4

  Dat[2] := 5

  Dat[3] := 4

  Dat[4] := 3

  Dat[5] := 2

  Dat[6] := 3

  Dat[7] := 4

  Dat[8] := 5

  Dat[9] := 5

  Dat[10] := 3

  m := 0

  нц для k от 1 до 10

    если Dat[k] > 3 то

    m := m + 1

  все

  кц

  вывод m

кон

Бейсик

DIM Dat(10) AS INTEGER

DIM k, m AS INTEGER

Dat(1) = 4: Dat(2) = 5

Dat(3) = 4: Dat(4) = 3

Dat(5) = 2: Dat(6) = 3

Dat(7) = 4: Dat(8) = 5

Dat(9) = 5: Dat(10) = 3

m = 0

FOR k = 1 TO 10

IF Dat(k) > 3 THEN

m = m + 1

ENDIF

NEXT k

PRINT m

END

Паскаль

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1] := 4; Dat[2] := 5;

  Dat[3] := 4; Dat[4] := 3;

  Dat[5] := 2; Dat[6] := 3;

  Dat[7] := 4; Dat[8] := 5;

  Dat[9] := 5; Dat[10] := 3;

  m := 0;

  for k := 1 to 10 do

    if Dat[k] > 3 then

      begin

        m := m + 1;

      end;

  writeln(m);

End.


№63 (Номер в базе opengia.com: Задание №8a2eb9 . Номер в базе ComputerScienceForAll.ru: 3884)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  цел s, k

  s:=0

  нц для k от 5 до 12

   s:=s+7

  кц

  вывод s

кон

DIM s,k AS INTEGER

s = 0

FOR k = 5 TO 12

 s = s + 7

NEXT k

PRINT s

END

Var s,k: integer;

Begin

 s:=0;

 for k:=5 to 12 do

   s:=s+7;

 write(s);

End.


№64 (Номер в базе opengia.com: Задание №8e2a7b . Номер в базе ComputerScienceForAll.ru: 3889)

В таблице Ball хранятся отметки по контрольной работе (Ball[1] – отметка 1 ученика, Ball[2] – отметка 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Ball[1:10]

  цел k, c

  Ball[1]:=4; Ball[2]:=5

  Ball[3]:=3; Ball[4]:=4

  Ball[5]:=2; Ball[6]:=5

  Ball[7]:=4; Ball[8]:=3

  Ball[9]:=4; Ball[10]:=5

  c:= 0

  нц для k от 1 до 10

    если Ball[k] >3 то

      c:=c+1

    все

  кц

  вывод c

кон

Бейсик

DIM Ball(10) AS INTEGER

DIM k, c AS INTEGER

Ball(1)=4: Ball(2)=5

Ball(3)=3: Ball(4)=4

Ball(5)=2: Ball(6)=5

Ball(7)=4: Ball(8)=3

Ball(9)=4: Ball(10)=5

c = 0

FOR k = 1 TO 10

IF Ball(k) >3 THEN

c=c+1

ENDIF

NEXT k

PRINT c

END

 

Паскаль

Var k, c: integer;

Ball: array[1..10] of integer;

Begin

  c:=0;

  Ball[1]:=4; Ball[2]:=5;

  Ball[3]:=3; Ball[4]:=4;

  Ball[5]:=2; Ball[6]:=5;

  Ball[7]:=4; Ball[8]:=3;

  Ball[9]:=4; Ball[10]:=5;

  for k:=1 to 10 do begin

    if Ball[k] >3 then

      c:=c+1;

  end;

  write(c);

End.

   


№65 (Номер в базе opengia.com: Задание №901597 . Номер в базе ComputerScienceForAll.ru: 3893)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] < 22  то

     m := m + Dat[k]

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF Dat(k) < 22 THEN

m = m + Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1  to 11 do

    if  Dat[k] < 22 then

      begin

        m := m + Dat[k]

      end;

  writeln(m)

End.


№66 (Номер в базе opengia.com: Задание №96e0c4 . Номер в базе ComputerScienceForAll.ru: 3924)

В таблице Tur хранятся данные о количестве ребят, ходивших в поход вместе с туристическим клубом "Полянка".  (Tur[1] – число ребят в 2001 году, Tur[2] – в 2002 и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

    целтаб Tur[1:11]

    цел k, m

    Tur[1] := 1; Tur[2] := 11

    Tur[3] := 8; Tur[4] := 12

    Tur[5] := 5; Tur[6] := 6

    Tur[7] := 15; Tur[8] := 16

    Tur[9] := 16; Tur[10] := 21

    Tur[11] := 7;

    m := 0

    нц для k от 1 до 11

        если Tur[k] < 10 то

         m := m + Tur[k]

        все

    кц

    вывод m

кон

Бейсик

DIM Tur(11) AS INTEGER

DIM k,m AS INTEGER

Tur(1)= 1: Tur(2)= 11

Tur(3)= 8: Tur(4) = 12

Tur(5)= 5: Tur(6)= 6

Tur(7)= 15: Tur(8)= 16

Tur(9)= 16: Tur(10)= 21

Tur(11)= 7

m = 0

FOR k = 1 TO 11

IF Tur(k) < 10 THEN

m = m + Tur(k)

END IF

NEXT k

PRINT m

Паскаль

Var k, m: integer;

  Tur: array[1..11] of integer;

Begin

  Tur[1] := 1;   Tur[2] := 11;

  Tur[3] := 8;  Tur[4] := 12;

  Tur[5] := 5;   Tur[6] := 6;

  Tur[7] := 15;  Tur[8] := 16;

  Tur[9] := 16;   Tur[10] := 21;

  Tur[11] := 7;  

  m := 0;

  For k := 1 to 11 Do

    If Tur[k] < 10 Then

      Begin

        m := m + Tur[k];

      End;

  Writeln(m);

End.


№67 (Номер в базе opengia.com: Задание №977BA0 . Номер в базе ComputerScienceForAll.ru: 3928)

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй
и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 2

  Dat[2] := 5

  Dat[3] := 7

  Dat[4] := 5

  Dat[5] := 4

  Dat[6] := 2

  Dat[7] := 0

  Dat[8] := 3

  Dat[9] := 4

  Dat[10] := 5

  m := 10

  нц для k от 1 до 10

    если Dat[k]<m то

     m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 2: Dat(2) = 5

Dat(3) = 7: Dat(4) = 5

Dat(5) = 4: Dat(6) = 2

Dat(7) = 0: Dat(8) = 3

Dat(9) = 4:Dat(10) = 5

m = 10 

FOR k = 1 TO 10

IF Dat(k)<m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 2; Dat[2] := 5;

 Dat[3] := 7; Dat[4] := 5;

 Dat[5] := 4; Dat[6] := 2;

 Dat[7] := 0; Dat[8] := 3;

 Dat[9] := 4; Dat[10] := 5;

 m := 10;

 for k := 1 to 10 do

   if  Dat[k]<m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


№68 (Номер в базе opengia.com: Задание №9a441f . Номер в базе ComputerScienceForAll.ru: 3978)

В таблице Ball хранятся отметки по контрольной работе (Ball[1] – отметка 1 ученика, Ball[2] – отметка 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг
  нач
  целтаб Ball[1:10]
  цел k, c
  Ball[1]:=4; Ball[2]:=5
  Ball[3]:=4; Ball[4]:=4
  Ball[5]:=2; Ball[6]:=5
  Ball[7]:=4; Ball[8]:=3
  Ball[9]:=4;Ball[10]:=5
  c:= 0
  нц для k от 1 до 10
   если Ball[k] <>4 то
     c:=c+1
   все
  кц
  вывод c
кон

DIM Ball(10) AS INTEGER
DIM k, c AS INTEGER
Ball(1)=4: Ball(2)=5
Ball(3)=4: Ball(4)=4
Ball(5)=2: Ball(6)=5
Ball(7)=4: Ball(8)=3
Ball(9)=4: Ball(10)=5
c = 0
FOR k = 1 TO 10
IF Ball(k) <>4 THEN
c=c+1
ENDIF
NEXT k
PRINT c
END

Var k, c: integer;
Ball:array[1..10] of integer;
Begin
  c:=0;
  Ball[1]:=4; Ball[2]:=5;
  Ball[3]:=4; Ball[4]:=4;
  Ball[5]:=2; Ball[6]:=5;
  Ball[7]:=4; Ball[8]:=3;
  Ball[9]:=4; Ball[10]:=5;
  for k:=1 to 10 do
    if Ball[k] <>4 then
       c:=c+1;
  write(c);
End.


№69 (Номер в базе opengia.com: Задание №9c156a . Номер в базе ComputerScienceForAll.ru: 3980)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 14 до 17

   s := s+8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 14 TO 17

s = s+8

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 14 to 17 do

   s := s+8;

 writeln(s);

End.


№70 (Номер в базе opengia.com: Задание №A97B46 . Номер в базе ComputerScienceForAll.ru: 4017)

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй
и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 2

  Dat[2] := 5

  Dat[3] := 8

  Dat[4] := 5

  Dat[5] := 4

  Dat[6] := 2

  Dat[7] := 0

  Dat[8] := 3

  Dat[9] := 4

  Dat[10] := 5

  m := 0

  нц для k от 1 до 10

    если Dat[k]>m  то

     m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 2: Dat(2) = 5

Dat(3) = 8: Dat(4) = 5

Dat(5) = 4: Dat(6) = 2

Dat(7) = 0: Dat(8) = 3

Dat(9) = 4:Dat(10) = 5

m = 0 

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 2; Dat[2] := 5;

 Dat[3] := 8; Dat[4] := 5;

 Dat[5] := 4; Dat[6] := 2;

 Dat[7] := 0; Dat[8] := 3;

 Dat[9] := 4;Dat[10] := 5;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


№71 (Номер в базе opengia.com: Задание №ABEA73 . Номер в базе ComputerScienceForAll.ru: 4023)

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] – количество учеников в первом классе, Dat[2] – во втором и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20

  Dat[2] := 27

  Dat[3] := 19

  Dat[4] := 28

  Dat[5] := 26

  Dat[6] := 22

  Dat[7] := 24

  Dat[8] := 28

  Dat[9] := 26

  Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] < 25 то

     m := m+1

    все

  кц

  вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20

Dat(2) = 27

Dat(3) = 19

Dat(4) = 28

Dat(5) = 26

Dat(6) = 22

Dat(7) = 24

Dat(8) = 28

Dat(9) = 26

Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF Dat(k) < 25 THEN

m = m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;

  Dat[2] := 27;

  Dat[3] := 19;

  Dat[4] := 28;

  Dat[5] := 26;

  Dat[6] := 22;

  Dat[7] := 24;

  Dat[8] := 28;

  Dat[9] := 26;

  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1 to 11 do

    if  Dat[k] < 25 then

      begin

        m := m+1

      end;

  writeln(m)

End.


№72 (Номер в базе opengia.com: Задание №B401EA . Номер в базе ComputerScienceForAll.ru: 4060)

В таблице Dat представлены данные о количестве голосов, поданных за
10 исполнителей народных песен (Dat[1] – количество голосов, поданных за первого исполнителя, Dat[2] – за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 56

  Dat[2] := 70

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 22

  Dat[7] := 30

  Dat[8] := 12

  Dat[9] := 65

  Dat[10] := 35

  m := 100

  нц для k от 1 до 10

    если Dat[k]<m то

     m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65:Dat(10) = 35

m = 100 

FOR k = 1 TO 10

IF Dat(k)<m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 56; Dat[2] := 70;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 22;

 Dat[7] := 30; Dat[8] := 12;

 Dat[9] := 65; Dat[10] := 35;

 m := 100;

 for k := 1 to 10 do

   if  Dat[k]<m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


№73 (Номер в базе opengia.com: Задание №CAA7DF . Номер в базе ComputerScienceForAll.ru: 4152)

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] – количество учеников в первом классе, Dat[2] – во втором и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] > 22 то

     m := m + 1

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF Dat(k) > 22 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1  to 11 do

    if  Dat[k] > 22 then

      begin

        m := m + 1

      end;

  writeln(m)

End.


№74 (Номер в базе opengia.com: Задание №CCE6A7 . Номер в базе ComputerScienceForAll.ru: 4169)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 0

  нц для k от 1 до 10

    если Dat[k] < 7  то

     m := m + 1

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 0 

FOR k = 1 TO 10

IF Dat(k) < 7 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0;

  for k := 1  to 10 do

    if  Dat[k] < 7 then

      begin

        m := m + 1

      end;

  writeln(m)

End.


№75 (Номер в базе opengia.com: Задание №D0484A . Номер в базе ComputerScienceForAll.ru: 4184)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если k > 9  то

     m := m + Dat[k]

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF k > 9 THEN

m = m + Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1  to 11 do

    if  k > 9 then

      begin

        m := m + Dat[k]

      end;

  writeln(m)

End.


№76 (Номер в базе opengia.com: Задание №D3A765 . Номер в базе ComputerScienceForAll.ru: 4199)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т.д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 0

  нц для k от 1 до 10

    если Dat[k] > 6  то

     m := m + 1

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 0 

FOR k = 1 TO 10

IF Dat(k) > 6 THEN

m = m+1

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0;

  for k := 1  to 10 do

    if  Dat[k] > 6 then

      m := m + 1;

  writeln(m)

End.


№77 (Номер в базе opengia.com: Задание №D8E0B4 . Номер в базе ComputerScienceForAll.ru: 4226)

В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1] – количество голосов, поданных за первого исполнителя, Dat[2] – за второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 56

  Dat[2] := 70

  Dat[3] := 20

  Dat[4] := 41

  Dat[5] := 14

  Dat[6] := 22

  Dat[7] := 30

  Dat[8] := 12

  Dat[9] := 65

  Dat[10] := 35

  m := 0

  нц для k от 1 до 10

    если Dat[k]>m то

     m := Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 56: Dat(2) = 70

Dat(3) = 20: Dat(4) = 41

Dat(5) = 14: Dat(6) = 22

Dat(7) = 30: Dat(8) = 12

Dat(9) = 65:Dat(10) = 35

m = 0 

FOR k = 1 TO 10

IF Dat(k)>m THEN

m = Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 56; Dat[2] := 70;

 Dat[3] := 20; Dat[4] := 41;

 Dat[5] := 14; Dat[6] := 22;

 Dat[7] := 30; Dat[8] := 12;

 Dat[9] := 65; Dat[10] := 35;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>m then

     begin

       m := Dat[k]

     end;

 writeln(m);

End.


№78 (Номер в базе opengia.com: Задание №E298DD . Номер в базе ComputerScienceForAll.ru: 4262)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 7; Dat[2] := 9

  Dat[3] := 10; Dat[4] := 5

  Dat[5] := 6; Dat[6] := 7

  Dat[7] := 9; Dat[8] := 8

  Dat[9] := 6; Dat[10] := 9

  m := 0

  нц для k от 1 до 10

    если Dat[k] < 7  то

     m := m + Dat[k]

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 7:  Dat(2) = 9

Dat(3) = 10: Dat(4) = 5

Dat(5) = 6:  Dat(6) = 7

Dat(7) = 9:  Dat(8) = 8

Dat(9) = 6:  Dat(10) = 9

m = 0 

FOR k = 1 TO 10

IF Dat(k) < 7 THEN

m = m + Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..10] of integer;

Begin

  Dat[1] := 7;  Dat[2] := 9;

  Dat[3] := 10; Dat[4] := 5;

  Dat[5] := 6;  Dat[6] := 7;

  Dat[7] := 9;  Dat[8] := 8;

  Dat[9] := 6;  Dat[10] := 9;

  m := 0;

  for k := 1  to 10 do

    if  Dat[k] < 7 then

      begin

        m := m + Dat[k]

      end;

  writeln(m)

End.


№79 (Номер в базе opengia.com: Задание №F252C9 . Номер в базе ComputerScienceForAll.ru: 4321)

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] – количество учеников в первом классе, Dat[2] – во втором и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] < 25  то

     m := m + 1

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF Dat(k) < 25 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1  to 11 do

    if  Dat[k] < 25 then

      begin

        m := m + 1

      end;

  writeln(m)

End.


№80 (Номер в базе opengia.com: Задание №F50B6F . Номер в базе ComputerScienceForAll.ru: 4327)

В таблице Dat хранятся данные измерений среднесуточной температуры за 10 дней в градусах (Dat[1] – данные за первый день, Dat[2] – за второй
и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

 алг

нач

  целтаб Dat[1:10]

  цел  k, m

  Dat[1] := 12

  Dat[2] := 15

  Dat[3] := 17

  Dat[4] := 15

  Dat[5] := 14

  Dat[6] := 12

  Dat[7] := 10

  Dat[8] := 13

  Dat[9] := 14

  Dat[10] := 15

  m := 0

  нц для k от 1 до 10

    если Dat[k]>12 то

     m := m+1

    все

  кц

  вывод m

кон

DIM Dat(10) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 12: Dat(2) = 15

Dat(3) = 17: Dat(4) = 15

Dat(5) = 14: Dat(6) = 12

Dat(7) = 10: Dat(8) = 13

Dat(9) = 14:Dat(10) = 15

m = 0 

FOR k = 1 TO 10

IF Dat(k)>12 THEN

m = m+1

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..10] of integer;

Begin

 Dat[1] := 12; Dat[2] := 15;

 Dat[3] := 17; Dat[4] := 15;

 Dat[5] := 14; Dat[6] := 12;

 Dat[7] := 10; Dat[8] := 13;

 Dat[9] := 14; Dat[10] := 15;

 m := 0;

 for k := 1 to 10 do

   if  Dat[k]>12 then

     begin

       m := m+1

     end;

 writeln(m);

End.


№81 (Номер в базе opengia.com: Задание №F95BCD . Номер в базе ComputerScienceForAll.ru: 4349)

В таблице Dat хранятся данные измерений среднесуточной температуры за неделю в градусах (Dat[1] – данные за понедельник, Dat[2] – за вторник и т.д.). Определите число, которое будет напечатано в результате выполнения следующего алгоритма, записанного на трёх алгоритмических языках.

Алгоритмический язык

алг

нач

   целтаб Dat[1:7]

   цел  k, m, day

   Dat[1]:=7;  Dat[2]:=9

   Dat[3]:=10; Dat[4]:=8

   Dat[5]:=6;  Dat[6]:=7

   Dat[7]:=6

   day:= 1; m:=Dat[1]

     нц для k от 2 до 7

         если Dat[k] < m то

     m:=Dat[k]; day:=k

         все

     кц

     вывод day

кон

Бейсик

DIM Dat(7) AS INTEGER

Dat(1)=7:  Dat(2)=9

Dat(3)=10: Dat(4)=8

Dat(5)=6:  Dat(6)=7

Dat(7)=6

day = 1: m=Dat(1)

FOR k = 2 TO 7

IF Dat(k) < m THEN

m=Dat(k)

day=k

END IF

NEXT k

PRINT day

END

Паскаль

Var k, m, day: integer;

 Dat: array[1..7] of integer;

Begin

   Dat[1]:=7;  Dat[2]:=9;

   Dat[3]:=10; Dat[4]:=8;

   Dat[5]:=6;  Dat[6]:=7;

   Dat[7]:=6; 

   day:= 1; m:=Dat[1];

   for k:=2 to 7 do begin

      if  Dat[k] < m then begin

          m:=Dat[k]; day:=k

      end

   end;

    write(day);

End.


№82 (Номер в базе opengia.com: Задание №F9FB6F . Номер в базе ComputerScienceForAll.ru: 4350)

В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 30

  нц для k от 1 до 11

    если Dat[k] < m  то

     m := Dat[k]

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 30 

FOR k = 1 TO 11

IF Dat(k) < m THEN

m = Dat(k)

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 30;

  for k := 1  to 11 do

    if  Dat[k] < m then

      begin

        m := Dat[k]

      end;

  writeln(m)

End.


№83 (Номер в базе opengia.com: Задание №FA0DC0 . Номер в базе ComputerScienceForAll.ru: 4351)

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] – количество учеников в первом классе, Dat[2] – во втором и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1] := 20; Dat[2] := 25

  Dat[3] := 19; Dat[4] := 25

  Dat[5] := 26; Dat[6] := 22

  Dat[7] := 24; Dat[8] := 28

  Dat[9] := 26; Dat[10] := 21

  Dat[11] := 27

  m := 0

  нц для k от 1 до 11

    если Dat[k] >= 25  то

     m := m + 1

    все

  кц

  вывод m

кон

Бейсик

Паскаль

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1) = 20: Dat(2) = 25

Dat(3) = 19: Dat(4) = 25

Dat(5) = 26: Dat(6) = 22

Dat(7) = 24: Dat(8) = 28

Dat(9) = 26: Dat(10) = 21

Dat(11) = 27

m = 0 

FOR k = 1 TO 11

IF Dat(k) >= 25 THEN

m = m + 1

END IF

NEXT k

PRINT m

Var k, m: integer;

 Dat: array[1..11] of integer;

Begin

  Dat[1] := 20;  Dat[2] := 25;

  Dat[3] := 19;  Dat[4] := 25;

  Dat[5] := 26;  Dat[6] := 22;

  Dat[7] := 24;  Dat[8] := 28;

  Dat[9] := 26;  Dat[10] := 21;

  Dat[11] := 27;

  m := 0;

  for k := 1  to 11 do

    if  Dat[k] >= 25 then

      begin

        m := m + 1

      end;

  writeln(m)

End.


№84 (Номер в базе opengia.com: Задание №a05385 . Номер в базе ComputerScienceForAll.ru: 4373)

В таблице Dat хранятся данные измерений роста учеников 4 класса в сантиметрах. (Dat[1] – рост первого ученика, Dat[2] – второго и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

целтаб Dat[1:10]

цел  k, n, d

Dat[1] := 120; Dat[2] := 130

Dat[3] := 110; Dat[4] := 150

Dat[5] := 120;  Dat[6] := 150

Dat[7] := 110; Dat[8] := 140

Dat[9] := 135; Dat[10] := 150

n := 1; d := Dat[1]

нц для k от 2 до 10

если Dat[k] < d то

d := Dat[k]; n := k

все

кц

вывод n

кон

Бейсик

DIM Dat(10) AS INTEGER

DIM k, n, d AS INTEGER

Dat(1) = 120: Dat(2) = 130

Dat(3) = 110: Dat(4) = 150

Dat(5) = 120: Dat(6) = 150

Dat(7) = 110: Dat(8) = 140

Dat(9) = 135: Dat(10) = 150

n = 1: d = Dat(1)

FOR k = 2 TO 10

IF Dat(k) < d THEN

d = Dat(k)

n = k

END IF

NEXT k

PRINT n

Паскаль

var k, n, d: integer;

Dat: array[1..10] of integer;

begin

Dat[1] := 120;  Dat[2] := 130;

Dat[3] := 110; Dat[4] := 150;

Dat[5] := 120;  Dat[6] := 150;

Dat[7] := 110; Dat[8] := 140;

Dat[9] := 135; Dat[10] := 150;

n := 1; d := Dat[1];

for k := 2 to 10 do

  begin

    if  Dat[k] < d then

    begin

      d := Dat[k]; n := k

    end;

  end;

write(n);

end.


№85 (Номер в базе opengia.com: Задание №aa4739 . Номер в базе ComputerScienceForAll.ru: 4385)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 13 до 17

   s := s+6

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 13 TO 17

s = s+6

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 13 to 17 do

   s := s+6;

 writeln(s);

End.


№86 (Номер в базе opengia.com: Задание №b4f41b . Номер в базе ComputerScienceForAll.ru: 4398)

В таблице A хранятся данные о количестве учеников опоздавших на занятия  за неделю (A[1] – данные за понедельник, A[2] – за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический

язык

алг

нач

  целтаб A[1:6]

  цел k, m, day

  A[1]:=5; A[2]:=4

  A[3]:=2; A[4]:=2

  A[5]:=4; A[6]:=3

  day:= 1; m:=A[1]

  нц для k от 2 до 6

    если A[k] <= m то

    m:=A[k]; day:=k

    все

  кц

  вывод day

кон

Бейсик

DIM A(6) AS INTEGER

A(1)=5: A(2)=4

A(3)=2: A(4)=2

A(5)=4: A(6)=3

day = 1: m=A(1)

FOR k = 2 TO 6

IF A(k) <= m THEN

m=A(k)

day=k

END IF

NEXT k

PRINT day

END

Паскаль

Var k, m, day: integer;

A: array[1..6] of integer;

Begin

  A[1]:=5; A[2]:=4;

  A[3]:=2; A[4]:=2;

  A[5]:=4; A[6]:=3;

  day:= 1; m:=A[1];

  for k:=2 to 6 do

    begin

      if A[k] <= m then

        begin

          m:=A[k];

          day:=k

         end

        end;

  write(day);

End.


№87 (Номер в базе opengia.com: Задание №b6b7bc . Номер в базе ComputerScienceForAll.ru: 4405)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 8,

 нц для k от 14 до 18

   s := s+6

кц

вывод s

кон

DIM k, s AS INTEGER

s = 8

FOR k = 14 TO 18

s = s+6

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 8;

 for k := 14 to 18 do

   s := s+6;

 writeln(s);

End.


№88 (Номер в базе opengia.com: Задание №b8a70e . Номер в базе ComputerScienceForAll.ru: 4408)

В таблице Dat хранятся данные ежедневных измерений температуры воздуха (Dat[1] – температура в понедельник, Dat[2] – во вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

целтаб Dat[1:7]

цел  k, day

Dat[1] := 9;  Dat[2] := 11

Dat[3] := 10; Dat[4] := 13

Dat[5] := 8;  Dat[6] := 5

Dat[7] := 11

day := 0

нц для k от 1 до 7

если Dat[k] <= 10 то

day := day+1

все

кц

вывод day

кон

Бейсик

DIM Dat(7) AS INTEGER

DIM k, day AS INTEGER

Dat(1) = 9:  Dat(2) = 11

Dat(3) = 10: Dat(4) = 13

Dat(5) = 8:  Dat(6) = 5

Dat(7) = 11

day = 0

FOR k = 1 TO 7

IF Dat(k) <= 10 THEN

day = day+1

END IF

NEXT k

PRINT day

END

Паскаль

var 

Dat: array[1..7] of integer;

k, day: integer;

begin

Dat[1] := 9;  Dat[2] := 11;

Dat[3] := 10; Dat[4] := 13;

Dat[5] := 8;  Dat[6] := 5;

Dat[7] := 11; 

day := 0;

for k := 1 to 7 do begin

if  Dat[k] <= 10 then

day := day+1;

end;

writeln(day);

end.


№89 (Номер в базе opengia.com: Задание №ba59cb . Номер в базе ComputerScienceForAll.ru: 4413)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

цел  a, k

a := 4

нц для k от 5 до 8

a := a + 2 * k

кц

вывод a

кон

Бейсик

DIM a, k AS INTEGER

a = 4

FOR k = 5 TO 8

a = a + 2 * k

NEXT k

PRINT a

Паскаль

var a, k : integer;

begin

a := 4;

for k := 5 to 8 do

a := a + 2 * k;

write(a);

end.


№90 (Номер в базе opengia.com: Задание №c018d5 . Номер в базе ComputerScienceForAll.ru: 4418)

В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] – количество учеников в первом классе, Dat[2] – во втором и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  целтаб Dat[1:11]

  цел  k, m

  Dat[1]:=20; Dat[2]:=25

  Dat[3]:=19; Dat[4]:=25

  Dat[5]:=26; Dat[6]:=23

  Dat[7]:=24; Dat[8]:=28

  Dat[9]:=26;Dat[10]:=21

  Dat[11]:=27

  m:=0

  нц для k от 1 до 11

    если Dat[k] < 23  то

     m:=m + Dat[k]

    все

  кц

  вывод m

кон

DIM Dat(11) AS INTEGER

DIM k,m AS INTEGER

Dat(1)=20: Dat(2)=25

Dat(3)=19: Dat(4)=25

Dat(5)=26: Dat(6)=23

Dat(7)=24: Dat(8)=28

Dat(9)=26: Dat(10)=21

Dat(11)=27

m = 0 

FOR k = 1 TO 11

IF Dat(k) < 23 THEN

m=m + Dat(k)

ENDIF

NEXT k

PRINT m

Var k, m: integer;

Dat: array[1..11] of integer;

Begin

  Dat[1]:=20;  Dat[2]:=25;

  Dat[3]:=19;  Dat[4]:=25;

  Dat[5]:=26;  Dat[6]:=23;

  Dat[7]:=24;  Dat[8]:=28;

  Dat[9]:=26;  Dat[10]:=21;

  Dat[11]:=27;

  m:=0;

  for k:=1 to 11 do

    if  Dat[k] < 23 then

        m:=m + Dat[k];

  writeln(m)

End.


№91 (Номер в базе opengia.com: Задание №c4f6b1 . Номер в базе ComputerScienceForAll.ru: 4426)

Сотрудник метеобюро в ходе измерений среднесуточной температуры записывал показания термометра в таблицу Tem.  (Tem[1] – температура, полученная в результате первого измерения, Tem[2] – второго и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

алг

нач

   целтаб Tem[1:12]

   цел k, b

   b := 15

   Tem[1] := 22; Tem[2] := 25

   Tem[3] := 20; Tem[4] := 18

   Tem[5] := 16; Tem[6] := 14

   Tem[7] := 20; Tem[8] := 23

   Tem[9] := 17; Tem[10] := 19

   Tem[11] := 20; Tem[12] := 21

   нц для k от 1 до 12

       если Tem[k] < 20 то

        b := b + 1

       все

   кц

   вывод b

кон

 

DIM Tem(12) AS INTEGER

DIM k,b AS INTEGER

b = 15

Tem(1)= 22:  Tem(2)= 25

Tem(3)= 20:  Tem(4) = 18

Tem(5)= 16:  Tem(6)= 14

Tem(7)= 20:  Tem(8)= 23

Tem(9)= 17:  Tem(10)= 19

Tem(11)= 20:  Tem(12)= 21

FOR k = 1 TO 12

IF Tem(k) < 20 THEN

b = b + 1

END IF

NEXT k

PRINT b

Паскаль

Var k, b: integer;

  Tem: array[1..12] of integer;

Begin

  b := 15;

  Tem[1] := 22;   Tem[2] := 25;

  Tem[3] := 20;   Tem[4] := 18;

  Tem[5] := 16;   Tem[6] := 14;

  Tem[7] := 20;   Tem[8] := 23;

  Tem[9] := 17;   Tem[10] := 19;

  Tem[11] := 20;   Tem[12] := 21;

  For k := 1 to 12 Do

    If Tem[k] < 20 Then

        b := b + 1;

  Writeln(b);

End.


№92 (Номер в базе opengia.com: Задание №c8ca85 . Номер в базе ComputerScienceForAll.ru: 4429)

В таблице Ves хранятся данные о весе в килограммах по группе учащихся спортивной школы (Ves[1] – вес первого учащегося, Ves[2] – вес второго учащегося и т. д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

целтаб Ves[1:14]

цел i, n

Ves[1] := 25; Ves[2] := 21

Ves[3] := 23; Ves[4] := 28

Ves[5] := 30; Ves[6] := 25

Ves[7] := 31; Ves[8] := 28

Ves[9] := 25; Ves[10] := 28

Ves[11] := 30; Ves[12] := 27

Ves[13] := 26; Ves[14] := 24

n := Ves[1]

нц для i от 1 до 14

если Ves[i] < n то

n := Ves[i]

все

кц

вывод n

кон

Бейсик

DIM Ves(14) AS INTEGER

DIM i, n AS INTEGER

Ves(1) = 25:  Ves(2) = 21

Ves(3) = 23: Ves(4) = 28

Ves(5) = 30:  Ves(6) = 25

Ves(7) = 31: Ves(8) = 28

Ves(9) = 25: Ves(10) = 28

Ves(11) = 30: Ves(12) = 27

Ves(13) = 26: Ves(14) = 24

n = Ves(1)

FOR i = 1 TO 14

IF Ves(i) < n THEN

n = Ves(i)

END IF

NEXT i

PRINT n

END

Паскаль

var

Ves: array[1..14] of integer;

i, n: integer;

begin

Ves[1] := 25;  Ves[2] := 21;

Ves[3] := 23; Ves[4] := 28;

Ves[5] := 30;  Ves[6] := 25;

Ves[7] := 31; Ves[8] := 28;

Ves[9] := 25; Ves[10] := 28;

Ves[11] := 30; Ves[12] := 27;

Ves[13] := 26; Ves[14] := 24;

n := Ves[1];

for i := 1 to 14 do begin

if Ves[i] < n then

n := Ves[i];

end;

writeln(n);

end.


№93 (Номер в базе opengia.com: Задание №ca4d29 . Номер в базе ComputerScienceForAll.ru: 4432)

В таблице Dat хранятся данные ежедневных измерений температуры морской воды (Dat[1] – температура в понедельник, Dat[2] – во вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

целтаб Dat[1:7]

цел  k, day

Dat[1] := 19;  Dat[2] := 21

Dat[3] := 20; Dat[4] := 23

Dat[5] := 24;  Dat[6] := 25

Dat[7] := 23

day := Dat[1]

нц для k от 1 до 7

если Dat[k] > day то

day := Dat[k]

все

кц

вывод day

кон

Бейсик

DIM Dat(7) AS INTEGER

DIM k, day AS INTEGER

Dat(1) = 19:  Dat(2) = 21

Dat(3) = 20: Dat(4) = 23

Dat(5) = 24:  Dat(6) = 25

Dat(7) = 23

day = Dat(1)

FOR k = 1 TO 7

IF Dat(k) > day THEN

day = Dat(k)

END IF

NEXT k

PRINT day

END

Паскаль

var

Dat: array[1..7] of integer;

k, day: integer;

begin

Dat[1] := 19;  Dat[2] := 21;

Dat[3] := 20; Dat[4] := 23;

Dat[5] := 24;  Dat[6] := 25;

Dat[7] := 23; 

day := Dat[1];

for k := 1 to 7 do begin

if  Dat[k] > day then

day := Dat[k]

end;

writeln(day);

end.


№94 (Номер в базе opengia.com: Задание №cafa97 . Номер в базе ComputerScienceForAll.ru: 4438)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 9,

 нц для k от 13 до 17

   s := s+7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 9

FOR k = 13 TO 17

s = s+7

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 9;

 for k := 13 to 17 do

   s := s+7;

 writeln(s);

End.


№95 (Номер в базе opengia.com: Задание №d2c03d . Номер в базе ComputerScienceForAll.ru: 4442)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

   цел s, k

   s := 0

   нц для k от 3 до 8

         s := s + 3 * k

   кц

   вывод s

кон

Бейсик

DIM s, k AS INTEGER

s = 0

FOR k = 3 TO 8

s = s + 3 * k

NEXT k

PRINT s

Паскаль

Var s, k : integer;

Begin

 s := 0;

 for k := 3 to 8 do

   s := s + 3 * k;

 write(s);

End.


№96 (Номер в базе opengia.com: Задание №d2dfa9 . Номер в базе ComputerScienceForAll.ru: 4443)

В таблице Dat хранятся данные ежедневных измерений количества осадков за неделю в миллиметрах (Dat[1] – данные за понедельник, Dat[2] – за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

целтаб Dat[1:7]

цел  k, day

Dat[1] := 14;  Dat[2] := 10

Dat[3] := 0; Dat[4] := 15

Dat[5] := 0;  Dat[6] := 15

Dat[7] := 10

day := 0;

нц для k от 1 до 7

если Dat[k] = 0 то

day := k

все

кц

вывод day

кон

Бейсик

DIM Dat(7) AS INTEGER

Dat(1) = 14:  Dat(2) = 10

Dat(3) = 0: Dat(4) = 15

Dat(5) = 0:  Dat(6) = 15

Dat(7) = 10

day = 0

FOR k = 1 TO 7

IF Dat(k) = 0 THEN

day=k

ENDIF

NEXT k

PRINT day

END

Паскаль

var k, day: integer;

Dat: array[1..7] of integer;

begin

Dat[1] := 14;  Dat[2] := 10;

Dat[3] := 0; Dat[4] := 15;

Dat[5] := 0;  Dat[6] := 15;

Dat[7] := 10; 

day := 0;

for k := 1 to 7 do

if  Dat[k] = 0 then

day := k;

write(day);

end.


№97 (Номер в базе opengia.com: Задание №d427a4 . Номер в базе ComputerScienceForAll.ru: 4445)

В таблице Ves хранятся данные о весе в килограммах по группе учащихся спортивной школы (Ves[1] – вес первого учащегося, Ves[2] – вес второго учащегося и т. д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

целтаб Ves[1:14]

цел i, n

Ves[1] := 25; Ves[2] := 21

Ves[3] := 23; Ves[4] := 28

Ves[5] := 30; Ves[6] := 25

Ves[7] := 31; Ves[8] := 28

Ves[9] := 25; Ves[10] := 28

Ves[11] := 30; Ves[12] := 27

Ves[13] := 26; Ves[14] := 24

n := 0

нц для i от 1 до 14

если Ves[i] > 26 то

n := n + 1

все

кц

вывод n

кон

Бейсик

DIM Ves(14) AS INTEGER

DIM i, n AS INTEGER

Ves(1) = 25: Ves(2) = 21

Ves(3) = 23: Ves(4) = 28

Ves(5) = 30: Ves(6) = 25

Ves(7) = 31: Ves(8) = 28

Ves(9) = 25: Ves(10) = 28

Ves(11) = 30: Ves(12) = 27

Ves(13) = 26: Ves(14) = 24

n = 0

FOR i = 1 TO 14

IF Ves(i) > 26 THEN

n = n + 1

END IF

NEXT i

PRINT n

END

Паскаль

var

Ves: array[1..14] of integer;

i, n: integer;

begin

Ves[1] := 25;  Ves[2] := 21;

Ves[3] := 23; Ves[4] := 28;

Ves[5] := 30;  Ves[6] := 25;

Ves[7] := 31; Ves[8] := 28;

Ves[9] := 25; Ves[10] := 28;

Ves[11] := 30; Ves[12] := 27;

Ves[13] := 26; Ves[14] := 24;

n := 0;

for i := 1 to 14 do begin

if Ves[i] > 26 then

n := n + 1

end;

writeln(n);

end.


№98 (Номер в базе opengia.com: Задание №da155e . Номер в базе ComputerScienceForAll.ru: 4450)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

  цел s, k

  s := 0

  нц для k от 2 до 9

    s := s + 2 * k

  кц

  вывод s

кон

Бейсик

DIM s, k AS INTEGER

s = 0

FOR k = 2 TO 9

 s = s + 2 * k

NEXT k

PRINT s

Паскаль

Var s, k: integer;

Begin

  s := 0;

  for k:=2 to 9 do

    s := s + 2 * k;

  write(s);

End.


№99 (Номер в базе opengia.com: Задание №e27385 . Номер в базе ComputerScienceForAll.ru: 4457)

В таблице Work хранятся данные о количестве заказов, принятых фирмой "Алоэ" с первого по 15 ноября.  (Work[1] – число заказов, принятых 1 ноября, Work[2] – 2 ноября и т. д.). Определите, какое число будет напечатано в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

алг

нач

    целтаб Work[1:15]

    цел k, m

    Work[1] := 5; Work[2] := 4

    Work[3] := 5; Work[4] := 7

    Work[5] := 6; Work[6] := 12

    Work[7] := 7; Work[8] := 3

    Work[9] := 9; Work[10] := 7

    Work[11] := 0;Work[12] := 9

    Work[13] := 1;Work[14] := 0

    Work[15] := 8

    m := 0

    нц для k от 1 до 15

        если Work[k] < 7 то

         m := m + k

        все

    кц

    вывод m

кон

Бейсик

DIM Work(15) AS INTEGER

DIM k,m AS INTEGER

Work(1)= 5: Work(2)= 4

Work(3)= 5: Work(4) = 7

Work(5)= 6: Work(6)= 12

Work(7)= 7: Work(8)= 3

Work(9)= 9: Work(10)= 7

Work(11)= 0: Work(12)= 9

Work(13)= 1: Work(14)= 0

Work(15)= 8

m = 0

FOR k = 1 TO 15

IF Work(k) < 7 THEN

m = m + k

END IF

NEXT k

PRINT m

Паскаль

Var k, m: integer;

  Work: array[1..15] of integer;

Begin

  Work[1] := 5;   Work[2] := 4;

  Work[3] := 5;   Work[4] := 7;

  Work[5] := 6;   Work[6] := 12;

  Work[7] := 7;   Work[8] := 3;

  Work[9] := 9;   Work[10] := 7;

  Work[11] := 0;  Work[12] := 9;  

  Work[13] := 1;  Work[14] := 0;  

  Work[15] := 8;    

  m := 0;

  For k := 1 to 15 Do

    If Work[k] < 7 Then

      Begin

        m := m + k;

      End;

  Writeln(m);

End.


№100 (Номер в базе opengia.com: Задание №ee52c5 . Номер в базе ComputerScienceForAll.ru: 4464)

В таблице Dat хранятся данные ежедневных измерений количества осадков за неделю в миллиметрах (Dat[1] – данные за понедельник, Dat[2] – за вторник и т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

алг

нач

целтаб Dat[1:7]

цел  k, m, day

Dat[1] := 14;

Dat[2] := 10

Dat[3] := 0; Dat[4] := 15

Dat[5] := 0;  Dat[6] := 15

Dat[7] := 10

day := 1; m := Dat[1]

нц для k от 2 до 7

если Dat[k] > m то

m := Dat[k]; day := k

все

кц

вывод day

кон

Бейсик

DIM Dat(7) AS INTEGER

Dat(1) = 14:  Dat(2) = 10

Dat(3) = 0: Dat(4) = 15

Dat(5) = 0:  Dat(6) = 15

Dat(7) = 10

day = 1: m = Dat(1)

FOR k = 2 TO 7

IF Dat(k) > m THEN

m = Dat(k)

day = k

END IF

NEXT k

PRINT day

END

Паскаль

var k, m, day: integer;

Dat: array[1..7] of integer;

begin

Dat[1] := 14;  Dat[2] := 10;

Dat[3] := 0; Dat[4] := 15;

Dat[5] := 0;  Dat[6] := 15;

Dat[7] := 10; 

day := 1; m := Dat[1];

for k := 2 to 7 do begin

if  Dat[k] > m then begin

m := Dat[k]; day := k

end;

end;

write(day);

end.


№101 (Номер в базе opengia.com: Задание №f283c9 . Номер в базе ComputerScienceForAll.ru: 4469)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  цел s, k

  s:=0

  нц для k от 3 до 10

    s:=s+13

  кц

  вывод s

кон

DIM s,k AS INTEGER

s = 0

FOR k = 3 TO 10

 s= s+13

NEXT k

PRINT s

END

Var s, k: integer;

Begin

 s:=0;

 for k:=3 to 10 do

   s:=s+13;

 write(s);

End.


№102 (Номер в базе opengia.com: Задание №f87a03 . Номер в базе ComputerScienceForAll.ru: 4474)

В таблице Ball хранятся отметки по контрольной работе (Ball[1] – отметка 1 ученика, Ball[2] – отметка 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующего алгоритма, записанного на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг
  нач
  целтаб Ball[1:10]
  цел k, c
  Ball[1]:=4; Ball[2]:=5
  Ball[3]:=3; Ball[4]:=4
  Ball[5]:=2; Ball[6]:=5
  Ball[7]:=4; Ball[8]:=3
  Ball[9]:=4;Ball[10]:=5
  c:= 0
  нц для k от 1 до 10
   если Ball[k] =4 то
     c:=c+1
   все
  кц
  вывод c
кон

DIM Ball(10) AS INTEGER
DIM k, c AS INTEGER
Ball(1)=4: Ball(2)=5
Ball(3)=3: Ball(4)=4
Ball(5)=2: Ball(6)=5
Ball(7)=4: Ball(8)=3
Ball(9)=4: Ball(10)=5
c = 0
FOR k = 1 TO 10
IF Ball(k) =4 THEN
c=c+1
ENDIF
NEXT k
PRINT c
END

Var k, c: integer;
Ball:array[1..10] of integer;
Begin
  c:=0;
  Ball[1]:=4; Ball[2]:=5;
  Ball[3]:=3; Ball[4]:=4;
  Ball[5]:=2; Ball[6]:=5;
  Ball[7]:=4; Ball[8]:=3;
  Ball[9]:=4; Ball[10]:=5;
  for k:=1 to 10 do
    if Ball[k] =4 then
       c:=c+1;
  write(c);
End.


№103 (Номер в базе opengia.com: Задание №fe6644 . Номер в базе ComputerScienceForAll.ru: 4478)

В таблице Dat хранятся данные о количестве сделанных заданий учениками (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  целтаб Dat[1:10]

  цел  k, n

  Dat[1]:=7; Dat[2]:=9

  Dat[3]:=10; Dat[4]:=5

  Dat[5]:=6; Dat[6]:=7

  Dat[7]:=9; Dat[8]:=8

  Dat[9]:=9; Dat[10]:=9

  n=0

  нц для k от 1 до 10

    если Dat[k] > 7  то

     n:=n+1

    все

  кц

  вывод n

кон

DIM Dat(10) AS INTEGER

DIM k, n AS INTEGER

Dat(1)=7: Dat(2)=9

Dat(3)=10:Dat(4)=5

Dat(5)=6: Dat(6)=7

Dat(7)=9: Dat(8)=8

Dat(9)=9: Dat(10)=9

n=0

FOR k = 1 TO 10

IF Dat(k) > 7 THEN

n=n+1

ENDIF

NEXT k

PRINT n

Var k, n: integer;

Dat: array[1..10] of integer;

Begin

  Dat[1]:=7;  Dat[2]:=9;

  Dat[3]:=10; Dat[4]:=5;

  Dat[5]:=6;  Dat[6]:=7;

  Dat[7]:=9;  Dat[8]:=8;

  Dat[9]:=9;  Dat[10]:=9;

  n:=0;

  for k:=1 to 10 do

    if  Dat[k] > 7 then

      n:=n+1;

  writeln(n)

End.


Leave a Comment

Лимит времени истёк. Пожалуйста, перезагрузите CAPTCHA.