В9 — ЯП — циклические алгоритмы

Всего заданий в разделе: 61


№1 (Номер в базе opengia.com: Задание №caf829 . Номер в базе ComputerScienceForAll.ru: 4437)

Запишите значение переменной k, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  цел k,i

  k := 4

  нц для i от 1 до 3

        k := 2*k + i

  кц

  вывод k

кон

DIM i,k AS INTEGER

k = 4

FOR i = 1 TO 3

k = 2*k + i

NEXT i

PRINT k

Var k,i: integer;

Begin

  k := 4;

  For i := 1 to 3 do

     k := 2*k + i;

  Writeln(k);

End.


№2 (Номер в базе opengia.com: Задание №b4db6c . Номер в базе ComputerScienceForAll.ru: 4395)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

цел  n, s

s := 1

нц для n от 3 до 8

s := s * 2

кц

вывод s

кон

DIM n, s AS INTEGER

s = 1

FOR n = 3 TO 8

s = s * 2

NEXT n

PRINT s

END

var s, n: integer;

begin

s := 1;

for n := 3 to 8 do

s := s * 2;

write(s);

end.


№3 (Номер в базе opengia.com: Задание №ac30c0 . Номер в базе ComputerScienceForAll.ru: 4389)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  цел s, n

  s := 5

  нц для n от 2 до 4

      s := s + (n-1)

  кц

  вывод s

кон

DIM s, n AS INTEGER

s = 5

FOR n = 2 TO 4

s = s + (n-1)

NEXT n

PRINT s

Var s,n: integer;

Begin

  s := 5;

  For n := 2 to 4 do

     s := s + (n-1);

  Writeln(s);

End.


№4 (Номер в базе opengia.com: Задание №a0600f . Номер в базе ComputerScienceForAll.ru: 4374)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

цел  n, s

s := 2

нц для n от 2 до 5

s := n + s * 2

кц

вывод s

кон

DIM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

s = n + s * 2

NEXT n

PRINT s

END

var s, n: integer;

begin

s := 2;

for n := 2 to 5 do

s := n + s * 2;

write(s);

end.


№5 (Номер в базе opengia.com: Задание №FE2DED . Номер в базе ComputerScienceForAll.ru: 4365)

Запишите значение переменой s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s:=0,

  нц для k от 1 до 10

  s:=s+14

кц

вывод s

кон

DIM k, s AS INTEGER

s=0

FOR k=1 TO 10

s=s+14

NEXT k

PRINT s

END

Var s,k: integer;

Begin

 s:=0;

 for k:=1 to 10 do

  s:=s+14;

 write(s);

End.


№6 (Номер в базе opengia.com: Задание №FAB32C . Номер в базе ComputerScienceForAll.ru: 4354)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 3 до 8

  s := s+7

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 8

s = s+7

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 3 to 8 do

   s := s+7;

 writeln(s);

End.


№7 (Номер в базе opengia.com: Задание №DC1FBE . Номер в базе ComputerScienceForAll.ru: 4236)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 8

 нц для k от 2 до 8

  s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 8

FOR k = 2 TO 8

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 8;

 for k := 2 to 8 do

   s := s + 8;

 writeln(s);

End.


№8 (Номер в базе opengia.com: Задание №C096E3 . Номер в базе ComputerScienceForAll.ru: 4109)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 5 до 11

  s := s + 6

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 5 TO 11

s = s + 6

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 5 to 11 do

   s := s + 6;

 writeln(s);

End.


№9 (Номер в базе opengia.com: Задание №2240aa . Номер в базе ComputerScienceForAll.ru: 3238)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

цел  a, k

a := 40

нц для k от 2 до 5

a := a – k

кц

вывод a

кон

DIM a, k AS INTEGER

a = 40

FOR k = 2 TO 5

a = a – k

NEXT k

PRINT a

var a, k : integer;

begin

a := 40;

for k := 2 to 5 do

a := a – k;

write(a);

end.


№10 (Номер в базе opengia.com: Задание №BC22BF . Номер в базе ComputerScienceForAll.ru: 4089)

Запишите значение переменой s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 6

 нц для k от 4 до 10

  s:=s+6

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 6

FOR k = 4 TO 10

s= s + 6

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 6;

 for k := 4 to 10 do

   s := s + 6;

 writeln(s);

End.


№11 (Номер в базе opengia.com: Задание №B55B29 . Номер в базе ComputerScienceForAll.ru: 4064)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 7

 нц для k от 2 до 8

  s := s + 7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 7

FOR k = 2 TO 8

s = s + 7

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 7;

 for k := 2 to 8 do

   s := s + 7;

 writeln(s);

End.


№12 (Номер в базе opengia.com: Задание №B49231 . Номер в базе ComputerScienceForAll.ru: 4061)

Запишите значение переменой s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s:=0,

  нц для k от 1 до 11

  s:=s+12

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 1 TO 11

s= s+12

NEXT k

PRINT s

END

Var s,k: integer;

Begin

 s:=0;

 for k:=1 to 11 do

  s:=s+12;

 write(s);

End.


№13 (Номер в базе opengia.com: Задание №B099F9 . Номер в базе ComputerScienceForAll.ru: 4049)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 4 до 8

  s := s+7

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 8

s = s+7

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 4 to 8 do

   s := s+7;

 writeln(s);

End.


№14 (Номер в базе opengia.com: Задание №3223ee . Номер в базе ComputerScienceForAll.ru: 3330)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 16 до 20

   s := s+10

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 16 TO 20

s = s+10

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 16 to 20 do

   s := s+10;

 writeln(s);

End.


№15 (Номер в базе opengia.com: Задание №AE38B2 . Номер в базе ComputerScienceForAll.ru: 4036)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 4 до 7

  s := s+8

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 7

s = s+8

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 4 to 7 do

   s := s+8;

 writeln(s);

End.


№16 (Номер в базе opengia.com: Задание №AC336E . Номер в базе ComputerScienceForAll.ru: 4028)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 4 до 8

  s := s + 13

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 8

s = s + 13

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 4 to 8 do

   s := s + 13;

 writeln(s);

End.


№17 (Номер в базе opengia.com: Задание №AB4668 . Номер в базе ComputerScienceForAll.ru: 4021)

Запишите значение переменой s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s:=100

  нц для k от 1 до 10

  s:=s+11

кц

вывод s

кон

DIM k, s AS INTEGER

s=100

FOR k=1 TO 10

s=s+11

NEXT k

PRINT s

END

Var s,k: integer;

Begin

 s:=100;

 for k:=1 to 10 do

  s:=s+11;

 write(s);

End.


№18 (Номер в базе opengia.com: Задание №A4155B . Номер в базе ComputerScienceForAll.ru: 4001)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 5 до 9

  s := s + 9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 5 TO 9

s = s + 9

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 5 to 9 do

   s := s + 9;

 writeln(s);

End.


№19 (Номер в базе opengia.com: Задание №448453 . Номер в базе ComputerScienceForAll.ru: 3427)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 14 до 18

   s := s+7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 14 TO 18

s = s+7

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 14 to 18 do

   s := s+7;

 writeln(s);

End.


№20 (Номер в базе opengia.com: Задание №48100a . Номер в базе ComputerScienceForAll.ru: 3448)

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык Бейсик Паскаль

алг

нач

   цел  n, s

   m := 0,

   нц для n от 1 до 10

      s := s + 7

кц

вывод s

кон

s = 0

FOR n = 1 TO 10

   s = s + 7

NEXT n

PRINT s

END

var s, n: integer;

begin

 s := 0;

 for n := 1 to 10 do

   s := s + 7;

 write(s);

end.


№21 (Номер в базе opengia.com: Задание №A14895 . Номер в базе ComputerScienceForAll.ru: 3988)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 3 до 8

  s := s + 11

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 8

s = s + 11

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 3 to 8 do

   s := s + 11;

 writeln(s);

End.


№22 (Номер в базе opengia.com: Задание №9F951D . Номер в базе ComputerScienceForAll.ru: 3973)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 3 до 7

  s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 7

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 3 to 7 do

   s := s + 8;

 writeln(s);

End.


№23 (Номер в базе opengia.com: Задание №9ECB07 . Номер в базе ComputerScienceForAll.ru: 3968)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 8

 нц для k от 4 до 8

  s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 8

FOR k = 4 TO 8

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 8;

 for k := 4 to 8 do

   s := s + 8;

 writeln(s);

End.


№24 (Номер в базе opengia.com: Задание №9CED75 . Номер в базе ComputerScienceForAll.ru: 3960)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 4 до 9

  s := s + 12

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 9

s = s + 12

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 4 to 9 do

   s := s + 12;

 writeln(s);

End.


№25 (Номер в базе opengia.com: Задание №9A1A10 . Номер в базе ComputerScienceForAll.ru: 3943)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 3 до 9

  s := s + 9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 9

s = s + 9

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 3 to 9 do

   s := s + 9;

 writeln(s);

End.


№26 (Номер в базе opengia.com: Задание №96FF20 . Номер в базе ComputerScienceForAll.ru: 3922)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 9

 нц для k от 4 до 7

  s := s + 9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 9

FOR k = 4 TO 7

s = s + 9

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 9;

 for k := 4 to 7 do

   s := s + 9;

 writeln(s);

End.


№27 (Номер в базе opengia.com: Задание №91885F . Номер в базе ComputerScienceForAll.ru: 3899)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 7 до 12

  s := s+11

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 7 TO 12

s = s+11

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 7 to 12 do

   s := s+11;

 writeln(s);

End.


№28 (Номер в базе opengia.com: Задание №9020A2 . Номер в базе ComputerScienceForAll.ru: 3894)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 6 до 9

  s := s+12

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 6 TO 9

s = s+12

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 6 to 9 do

   s := s+12;

 writeln(s);

End.


№29 (Номер в базе opengia.com: Задание №8ef279 . Номер в базе ComputerScienceForAll.ru: 3891)

Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  цел d,n,i

  n :=4

  d := n*2

  нц для i от 1 до 3

     d := d + 2*i

  кц

  вывод d

кон

 

DIM d,n,i AS INTEGER

n = 4

d = n*2

FOR i = 1 TO 3

d = d + 2*i

NEXT i

PRINT d

Var d,n,i:integer;

Begin

  n := 4;

  d := n*2;

  For i := 1 to 3 do

     d := d + 2*i;

  Writeln(d);

End.


№30 (Номер в базе opengia.com: Задание №7C1FCB . Номер в базе ComputerScienceForAll.ru: 3769)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 9

 нц для k от 2 до 7

  s := s + 9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 9

FOR k = 2 TO 7

s = s + 9

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 9;

 for k := 2 to 7 do

   s := s + 9;

 writeln(s);

End.


№31 (Номер в базе opengia.com: Задание №74dd35 . Номер в базе ComputerScienceForAll.ru: 3726)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

   цел k,i

   k := 2

   нц для i от 0 до 2

         k := 3*k + i

   кц

   вывод k

кон

DIM i,k AS INTEGER

k = 2

FOR i = 0 TO 2

k = 3*k + i

NEXT i

PRINT k

Var k,i: integer;

Begin

  k := 2;

  For i := 0 to 2 do

     k := 3*k + i;

  Writeln(k);

End.


№32 (Номер в базе opengia.com: Задание №710F4F . Номер в базе ComputerScienceForAll.ru: 3706)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 7

 нц для k от 3 до 9

  s := s + 7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 7

FOR k = 3 TO 9

s = s + 7

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 7;

 for k := 3 to 9 do

   s := s + 7;

 writeln(s);

End.


№33 (Номер в базе opengia.com: Задание №6E7163 . Номер в базе ComputerScienceForAll.ru: 3672)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 4 до 8

  s := s+6

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 8

s = s+6

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 4 to 8 do

   s := s+6;

 writeln(s);

End.


№34 (Номер в базе opengia.com: Задание №6BBBCA . Номер в базе ComputerScienceForAll.ru: 3660)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 9 до 13

  s := s+9

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 9 TO 13

s = s+9

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 9 to 13 do

   s := s+9;

 writeln(s);

End.


№35 (Номер в базе opengia.com: Задание №693F65 . Номер в базе ComputerScienceForAll.ru: 3649)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 6 до 12

  s := s+10

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 6 TO 12

s = s+10

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 6 to 12 do

   s := s+10;

 writeln(s);

End.


№36 (Номер в базе opengia.com: Задание №6487d2 . Номер в базе ComputerScienceForAll.ru: 3614)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  n, s

s := 0

нц для n от 3 до 7

s := s + 2 * n

кц

вывод s

кон

 

DIM n, s AS INTEGER

s = 0

FOR n = 3 TO 7

s = s + 2 * n

NEXT n

PRINT s

END

var n, s: integer;

begin

s := 0;

for n := 3 to 7 do

s := s + 2 * n;

write(s);

end.


№37 (Номер в базе opengia.com: Задание №5cdc59 . Номер в базе ComputerScienceForAll.ru: 3580)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

   цел y,i

   y := 0

   нц для i от 1 до 3

         y := y + 4*i

   кц

   вывод y

кон

DIM i,y AS INTEGER

y = 0

FOR i = 1 TO 3

y = y + 4*i

NEXT i

PRINT y

Var y,i: integer;

Begin

  y := 0;

  For i := 1 to 3 do

    y := y + 4*i;

  Writeln(y);

End.


№38 (Номер в базе opengia.com: Задание №59782C . Номер в базе ComputerScienceForAll.ru: 3550)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 7

 нц для k от 4 до 8

  s := s + 7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 7

FOR k = 4 TO 8

s = s + 7

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 7;

 for k := 4 to 8 do

   s := s + 7;

 writeln(s);

End.


№39 (Номер в базе opengia.com: Задание №56e048 . Номер в базе ComputerScienceForAll.ru: 3538)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

цел  n, s

s := 1

нц для n от 5 до 8

s := s * 3

кц

вывод s

кон

DIM n, s AS INTEGER

s = 1

FOR n = 5 TO 8

s = s * 3

NEXT n

PRINT s

END

var s, n: integer;

begin

s := 1;

for n := 5 to 8 do

s := s * 3;

write(s);

end.


№40 (Номер в базе opengia.com: Задание №573DDD . Номер в базе ComputerScienceForAll.ru: 3539)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 6 до 10

  s := s+10

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 6 TO 10

s = s+10

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 6 to 10 do

   s := s+10;

 writeln(s);

End.


№41 (Номер в базе opengia.com: Задание №521e96 . Номер в базе ComputerScienceForAll.ru: 3518)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  цел s, i

  s := 3

  нц для i от 2 до 5

       s := s + 2*i

  кц

  вывод s

кон

DIM i,s AS INTEGER

s = 3

FOR i = 2 TO 5

s = s + 2*i

NEXT i

PRINT s

Var s,i:integer;

Begin

  s := 3;

  For i := 2 to 5 do

     s := s + 2*i;

  Writeln(s);

End.


№42 (Номер в базе opengia.com: Задание №4FF483 . Номер в базе ComputerScienceForAll.ru: 3495)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 3 до 8

  s := s+9

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 8

s = s+9

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 3 to 8 do

   s := s+9;

 writeln(s);

End.


№43 (Номер в базе opengia.com: Задание №4439F0 . Номер в базе ComputerScienceForAll.ru: 3426)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 3 до 7

  s := s+6

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 7

s = s+6

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 3 to 7 do

   s := s+6;

 writeln(s);

End.


№44 (Номер в базе opengia.com: Задание №438646 . Номер в базе ComputerScienceForAll.ru: 3421)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 9

 нц для k от 3 до 7

  s := s + 9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 9

FOR k = 3 TO 7

s = s + 9

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 9;

 for k := 3 to 7 do

   s := s + 9;

 writeln(s);

End.


№45 (Номер в базе opengia.com: Задание №3F95B6 . Номер в базе ComputerScienceForAll.ru: 3392)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 8 до 12

  s := s+12

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 8 TO 12

s = s+12

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 8 to 12 do

   s := s+12;

 writeln(s);

End.


№46 (Номер в базе opengia.com: Задание №361b09 . Номер в базе ComputerScienceForAll.ru: 3348)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

  цел d,n

  d := 5

  d := d-3

  нц для n от 1 до 4

        d := d + n

  кц

  вывод d

кон

DIM n,d AS INTEGER

d = 5

d = d-3

FOR n = 1 TO 4

d = d + n

NEXT n

PRINT d

Var d,n: integer;

Begin

  d := 5;

  d := d-3;

  For n := 1 to 4 do

    d := d + n;

  Writeln(d);

End.


№47 (Номер в базе opengia.com: Задание №3A50D4 . Номер в базе ComputerScienceForAll.ru: 3373)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 8

 нц для k от 3 до 8

  s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 8

FOR k = 3 TO 8

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 8;

 for k := 3 to 8 do

   s := s + 8;

 writeln(s);

End.


№48 (Номер в базе opengia.com: Задание №30b8eb . Номер в базе ComputerScienceForAll.ru: 3325)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел n, s

s := 2

нц для n от 2 до 5

s := s + n * 2

кц

вывод s

кон

DIM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

s = s + n * 2

NEXT n

PRINT s

END

var s, n: integer;

begin

s := 2;

for n := 2 to 5 do

s := s + n * 2;

write(s);

end.


№49 (Номер в базе opengia.com: Задание №2437C7 . Номер в базе ComputerScienceForAll.ru: 3252)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 13 до 16

  s := s+14

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 13 TO 16

s = s+14

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 13 to 16 do

   s := s+14;

 writeln(s);

End.


№50 (Номер в базе opengia.com: Задание №232509 . Номер в базе ComputerScienceForAll.ru: 3249)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 2 до 8

  s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 2 TO 8

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

 s :=0;

 for k := 2 to 8 do

   s := s + 8;

 writeln(s);

End.


№51 (Номер в базе opengia.com: Задание №22FFCE . Номер в базе ComputerScienceForAll.ru: 3243)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 5 до 9

  s := s+8

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 5 TO 9

s = s+8

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 5 to 9 do

   s := s+8;

 writeln(s);

End.


№52 (Номер в базе opengia.com: Задание №20569d . Номер в базе ComputerScienceForAll.ru: 3219)

Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

   цел d,n,i

   n :=3

   d := n*3

   нц для i от 1 до 3

         d := d + i

   кц

   вывод d

кон

 

DIM d,n,i AS INTEGER

n = 3

d = n*3

FOR i = 1 TO 3

d = d + i

NEXT i

PRINT d

Var d,n,i: integer;

Begin

  n := 3;

  d := n*3;

  For i := 1 to 3 do

     d := d + i;

  Writeln(d);

End.


№53 (Номер в базе opengia.com: Задание №1F4DBF . Номер в базе ComputerScienceForAll.ru: 3204)

Запишите значение переменой s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s:=5

 нц для k от 5 до 11

  s := s + 5

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 5

FOR k = 5 TO 11

s= s + 5

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 5;

 for k := 5 to 11 do

   s := s + 5;

 writeln(s);

End.


№54 (Номер в базе opengia.com: Задание №1E4818 . Номер в базе ComputerScienceForAll.ru: 3200)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 4 до 9

  s := s + 10

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 9

s = s + 10

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 4 to 9 do

   s := s + 10;

 writeln(s);

End.


№55 (Номер в базе opengia.com: Задание №1210de . Номер в базе ComputerScienceForAll.ru: 3131)

Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

  цел d,n

  d := 6

  d := d-2

  нц для n от 1 до 4

        d := d + n

  кц

  вывод d

кон

DIM n,d AS INTEGER

d = 6

d = d-2

FOR n = 1 TO 4

d = d + n

NEXT n

PRINT d

Var d,n: integer;

Begin

  d := 6;

  d := d-2;

  For n := 1 to 4 do

    d := d + n;

  Writeln(d);

End.


№56 (Номер в базе opengia.com: Задание №1088A5 . Номер в базе ComputerScienceForAll.ru: 3127)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 12 до 15

  s := s+13

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 12 TO 15

s = s+13

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 12 to 15 do

   s := s+13;

 writeln(s);

End.


№57 (Номер в базе opengia.com: Задание №0803B5 . Номер в базе ComputerScienceForAll.ru: 3064)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 4 до 10

  s := s + 11

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 10

s = s + 11

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 4 to 10 do

   s := s + 11;

 writeln(s);

End.


№58 (Номер в базе opengia.com: Задание №01E981 . Номер в базе ComputerScienceForAll.ru: 3030)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 6 до 12

  s := s + 5

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 6 TO 12

s = s + 5

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 6 to 12 do

   s := s + 5;

 writeln(s);

End.


№59 (Номер в базе opengia.com: Задание №03C6F2 . Номер в базе ComputerScienceForAll.ru: 3048)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 7 до 11

  s := s+11

кц

вывод s

кон

 

DIM k, s AS INTEGER

s = 0

FOR k = 7 TO 11

s = s+11

NEXT k

PRINT s

Var s,k: integer;

Begin

 s := 0;

 for k := 7 to 11 do

   s := s+11;

 writeln(s);

End.


№60 (Номер в базе opengia.com: Задание №d2efba . Номер в базе ComputerScienceForAll.ru: 4444)

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  n, s

s := 1

нц для n от 2 до 5

s := s * 3

кц

вывод s

кон

 

DIM n, s AS INTEGER

s = 1

FOR n = 2 TO 5

s = s * 3

NEXT n

PRINT s

END

var n, s: integer;

begin

s := 1;

for n := 2 to 5 do

s := s * 3;

write(s);

end.


№61 (Номер в базе opengia.com: Задание №e2758f . Номер в базе ComputerScienceForAll.ru: 4458)

Запишите значение переменной y, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык Бейсик Паскаль

алг

нач

   цел y,i

   y := 5

   нц для i от 1 до 3

         y := y + 5*i

   кц

   вывод y

кон

алг

нач

   цел y,i

   y := 5

   нц для i от 1 до 3

         y := y + 5*i

   кц

   вывод y

кон

Var y,i: integer;

Begin

  y := 5;

  For i := 1 to 3 do

    y := y + 5*i;

  Writeln(y);

End.


Leave a Comment

Лимит времени истёк. Пожалуйста, перезагрузите CAPTCHA.